Configuração Wpad com DHCP habilitado no Pfsense 2.0 ( Dúvidas)



  • Olá pessoal  ;)

    Faz tempo que não entro no fórum e como vi que falta um tutorial de como configurar o script wpad (Web Proxy Auto-Discovery protocol) com o DHCP do pfsense habilitado decidi criar um tópico para tirar algumas dúvidas,reuniar algumas informações que tenho e que vocês membros do fórum podem me ajudar a agregar.Ao final vou criar um tutorial detalhado de todos os procedimentos.

    No meu caso, tenho como servidor DHCP o próprio PFsense e DNS windows 2003 que possuem o IP 192.168.1.253/16 (pfsense), e um servidor dns 192.168.0.103/16. Vamos primeiramente a configuração do wpad no pfsense:

    Script wpad :

    function FindProxyForURL(url, host)
    {
    return "PROXY 192.168.1.253:3128";
    }
    

    Agora vamos na pasta

    Acesse o diretório principal do servidor pfsense. No caso usr/local/www/, então basta criar um arquivo wpad.dat no diretório (não é necessário modificar as permissões do arquivo, e nem o dono do mesmo).

    No pfsense em System>General Setup temos Hostname : teste / Domain: firewall.com então fica como teste.firewall.com .

    Em dns forwarder coloquei :

    Host: teste
    Domain: firewall.com
    IP Address: 192.168.1.253 (pfsense)
    Description: WPAD

    Para terminar fui no DHCP em:

    DHCP - Additional BOOTP/DHCP Options
    Number: 252
    Type: text
    Value: http://192.168.1.253/wpad.dat

    Porém ao final não funcionou no navegador  :( … mesmo deixando marcado como "Detectar automaticamente as configurações" e tenho certeza que estou esquecendo de um pequeno detalhe  :-.

    Se alguém tiver alguma ideia posta aqui que vou testar tudo e fazer um tutorial pra galera.

    Grato





  • Obrigado pela resposta !

    Mas estou tentando aplicar tal solução no pfsense como web server e dhcp  ;) nesse tutorial é utilizado windows 2008 no procedimento.



  • sim amigo,

    se vc já tem um 2003, pq não usar ele como web server ?



  • @vina18:

    Porém ao final não funcionou no navegador  :( … mesmo deixando marcado como "Detectar automaticamente as configurações" e tenho certeza que estou esquecendo de um pequeno detalhe  :-.

    Se alguém tiver alguma ideia posta aqui que vou testar tudo e fazer um tutorial pra galera.

    Você tentou acessar o wpad direto pelo browser, para ver se o servidor web do pfsense permite download de arquivo .wpad/,pac?



  • Minha situação é bem parecida, mas, estou tentando fazer tudo somente com pfsense.

    pfsense
    ip 192.168.1.1
    hostname = pfsense
    domain = teste.com

    dns forwarder
    somente enable dns forwarder marcado

    host overrides
    host = wpad
    domain = teste.com
    ip address = 192.168.1.1

    DHCP - Additional BOOTP/DHCP Options
    Number: 252
    Type: text
    Value: http://192.168.1.1/wpad.dat

    regras do firewall - LAN
    1ª - antilockout - automatica
    2ª - TCP * * * 80 (HTTP) * none          BLOCK
    3ª - TCP * * * 443 (HTTPS) * none  BLOCK

    Se eu deixar o browser em automatico, nao navega, porem, se eu especificar script com configuraçao automatica e colocar o endereco "http://192.168.1.1/wpad.dat" funciona IE e firefox.

    Mesmo quando o browser está em automatico e não consigo navegar, se digitar o endereço "http://192.168.1.1/wpad.dat ou http://192.168.1.1/wpad.da ou http://192.168.1.1/proxy.pac" consigo fazer o download do arquivo.

    O ping para wpad.teste.com tambem funciona.

    Onde será que está meu erro?



  • Hoje consegui fazer o IE funcionar em modo automatico, porem, o Chrome que utiliza as mesmas configurações do IE ainda não funciona. O firefox também não funciona.
    Para o IE funcionar, redefini suas configurações para padrões de fabrica e já funcionou.

    Continua a luta para, pelo menos, o firefox funcionar.


Log in to reply