New install of 2.1 - same with 2.0.1 - NIC only properly works in safe mode?



  • I finally was able to get pfsense working on this machine:
    eMachine t3418
    CPU Sempron 3400+
    RAM 1.5GB DDR
    100GB Sata 2.5" drive
    Intel PRO/1000 dual port GB NIC.

    Onboard NIC is disabled as well as everything else I could disable in BIOS.

    The problem is that the NIC will not get an IP from the modem on the WAN port, nor will it give out IP addresses on the LAN port unless I boot into safe mode.

    Even disabling the DHCP server on the LAN port and manually assigning IP adresses to my computers would not work. I wasn't even able to ping the LAN port on the pfsense box.

    I spent a crazy amount of time on this… installed 2.0.1, tried Live CD of 2.0.1, tried Live CD of 2.1, tried regular mode.. tried non-ACPI mode.

    Even put the NIC in my main rig and ran the Live CD which worked fine.

    I am not sure what is causing it to only work in safe mode on the eMachines box.. but it looks like it could be some driver issue since it looks like safe mode doesn't load all of the drivers that regular and non-ACPI mode loads.

    Is there any way to force it to always start up in safe mode? Or even better, a way to figure out exactly what is causing the NIC to only function properly in safe mode on this machine?



  • Got it fixed.

    Had to make:
    loader.conf.local

    and add:
    hint.apic.0.disabled=1

    On reboot, it works fine in normal mode.

    Safe mode disables a few more things like DMA, APCI, SMP, and hdd caching.


Log in to reply