Serial Terminal: Enabling = Console "hangs"



  • Before logging this as a bug, I wanted a sanity check to see if there was something I was missing.

    Under System/Advanced, on the Admin Access Tab, "Serial Communications" section. If I check the Serial Terminal check box (regardless of speed settings),

    Upon boot, the VGA output hangs right after the SMP CPU #1 message, then never gets anymore output.
    Further, on the console (using Putty & a Null Modem cable), it appears to hang around the same spot.

    You never get the menu options, and doing a shutdown SOMETIMES after a very long time, it will shutdown or restart. Sometimes it seems to hang forever (or my patience ends after 10 or so minutes).

    This is on a DC2500CC motherboard, Serial Port 1.
    Build: 2.1-BETA0 (amd64)
    built on Tue Sep 4 16:39:48 EDT 2012

    I just tried using 2.0.1, and actually can reproduce the same results.

    Any suggestions? Recommended logs to gather?

    Thanks!



  • This is on a DC2500CC motherboard
    You mean D2500CC?  :-\

    Try nanobsd images with no VGA output like pfSense-2.1-BETA0-4g-i386-nanobsd-20120904-1639.img.gz
    You can find it here http://snapshots.pfsense.org/FreeBSD_RELENG_8_3/i386/pfSense_HEAD/nanobsd/?C=M;O=D

    I have the D2500CC and have tried serial output with 2.0 (nanobsd, but with VGA enabled) via 232-bluetooth adapter…
    All I remember - I could not get serial to work, but when when it was physically disconnected pfsense booted (VGA stops working when BTX shows turning "/") and webgui worked for that time it was needed to disable serial :)



  • Ah, you are correct, D2500CC. :)

    I considered the NanoBSD, but I just upgraded from a little Alix board for the long term plan of loading up Squid/Dansguardian and a few other toys. I really wanted to keep it as simple as I could with a load on the mirrored hard drives (gmirror).

    Getting NanoBSD loaded up on the drives with those packages setup, etc, seemed like a lot of customization I was scared to tackle. :(



  • I mean just try it out, if serial works and let us know.
    Use flash drive for nanobsd version, do minimal configuration and check serial again. If it does not work, then it should be something on hardware level. Unfortunately I can't test mine D2500CC since it is working in production 24/7



  • Not where I can easily do that either, as this device is currently in use as well.  At some point if I get a moment, I might put my spare Alix board back in it's place and test it.

    If anyone else has ideas, or any logs I can grab during a failed bootup, I'm more than happy to grab them.

    Thanks!



  • Let me ask this:

    Is anyone actually using this feature that can verify it works on their hardware?



  • EDIT: I thought this was the same issue as described in another thread. However, it was referring to VGA Console issues with the newer ATOM chips, not the Serial Console. (The VGA Console issue is resolved in current builds of 2.1, however, the Serial Console issue is not.)


  • Rebel Alliance Developer Netgate

    What exact image are you running and with what kernel?

    Full install with the SMP kernel? Embedded kernel?
    NanoBSD+VGA?

    I checked in a bunch of fixes last week for NanoBSD+VGA so I know that works well at the moment, and I have VMs full installs and active serial consoles so I know that does work there… And my edge router has a full install+embedded kernel and the serial console works there, too.

    It's possible this is specific to your hardware, but there really isn't enough info here yet to go on to even properly try to reproduce it.



  • The build is:

    Build: 2.1-BETA0 (amd64)
    built on Tue Sep 4 16:39:48 EDT 2012

    The kernel is SMP.

    The install was a full install done on the same date as the build. It was not an upgrade.

    What other information can I collect?


  • Rebel Alliance Developer Netgate

    On that very same build, I have a VM. I enable serial, console is ok. Reboot, and both consoles are active. Boot log (aside from dmesg) goes to the serial console, kernel messages go to both, at the end of the boot process, both consoles get a menu.

    So it seems to be OK in general, must be something specific to the serial on that hardware somehow.



  • I can also add when I had the 2.1 BETA build on AMD64 a week or two ago I was using the serial console along with VGA. There is a point where VGA no longer keeps getting all of the messages that the console did, but everything seemed to be working fine. I would guess it's something specific to that board as well.


  • Rebel Alliance Developer Netgate

    Yes how it works is that when both are active, only one can be the "primary" to receive output from programs running on the "console".

    Kernel messages will go to both - that includes things like hardware detection, link state messages, and so on.

    The output from our bootup scripts (initializing this and that, starting this and that, etc, etc) will only show on the serial console.

    At the end of the bootup sequence, a menu should appear on both the serial and video console.



  • Both VGA & Serial both get outputs up to about the line about the SMP CPU message. Then BOTH stop. You can never get a menu on either.

    After that, shutting down may work, may take 20 minutes, may not work at all.

    Although the WebGUI will work. I have considerd disabling all onboard Serial and plugging in a PCI Serial card to see if I could work around the issue that way. Shy of that, I may try to find a cheap single port IP KVM.

    I do know this is one of the new Atoms that only recently got the video issues resolved. I wonder if this is just another issue specific to this board as well. It's ashame, as it's a nice cheap ITX board with 2 Intel nics on it.



  • I have had this issue with a pfSense 2.1 snapshot four weeks ago on a Jetway NF99FL-525.

    I'm currently struggling with a console hang with a 4g nanobsd_vga image of pfSense 2.0.1 with an enabled serial console. The behavior is not exactly as yours but I suppose at least related. Main difference is that I can see boot messages on the serial console until getty is started. Then console hangs. Details are described in the thread D2500CC/D2500CCE and serial port install.

    Please let me know, if I can contribute to solving the serial console issue because I would really like to fully use the serial console of my Jetway. While testing new nanobsd images I could switch back my active firewall from the Jetway board to my previous alix machine - still working rock solid.

    Peter

    EDIT: Well file extension .log is not allowed for attachments, have to attach files with different extension.
    EDIT: Ups, whole posting lost and attachments added to my old posting, deleted again. Have to repost.



  • I'm back with additional and more detailed results about my serial console problem on a Jetway NF99FL-525 (COM1, external). I've decided to continue the current thread because I've tested the latest 2.1 snapshot nanobsd image besides the 2.0.1 release nanobsd image. The additionally tested images are:

    • pfSense-2.0.1-RELEASE-4g-amd64-nanobsd.img
    • pfSense-2.1-BETA0-4g-amd64-nanobsd-20120914-1237.img

    Both images behave exactly the same, e.g.:

    • Boot messages start with the boot loader menu where I can even select the boot slice.
    • All boot messages are visible until root filesystem is mounted.
    • From here no more messages are shown and no keyboard input is accepted.
    • System does not complete boot sequence and hangs completely, e.g. cannot be accessed via webGUI.

    Please find the full boot messages to the serial console of both images in the files attached.

    My previously described results were gained with a 2.0.1 nanobsd_vga image (pfSense-2.0.1-RELEASE-4g-amd64-nanobsd_vga.img) where I have manually activated the serial console. This image still works fine after activation of serial console. The serial console even shows some more messages but finally hangs as well.

    I can remember one of my numerous testings even with a full install of pfSense 2.0.1 on this board. The system worked as expected as long as I rebooted after activation of the serial console via the webGUI. In this case the system hang in a very early state, similar as described in Eurisko's initial posting. As I am running this board in headless mode only (have no spare keyboard/monitor) I did no further testing with full installs.

    Please let me know, if I can contribute narrow down the serial console issue. There seems to be some hardware out there (Firebox, Intel D2500CC and Jetway NF99FL-525) having issues with the serial console.

    Peter

    EDIT: Fixed some typos.

    pfsense_21_jetway_4g_nanobsd.txt
    pfsense_201_jetway_4g_nanobsd.txt



  • I was able to test over the weekend with the same 2.01 image (fSense-2.0.1-RELEASE-4g-amd64-nanobsd.img) and yielded the same results. Seems to work for a brief minute, but quickly hangs.

    I can only assume it's a serial driver bug with this board?

    I'm open to any debug diagnostics requested. I'm game to try anything to try to find a resolution to this issue.

    Thanks!


  • Rebel Alliance Developer Netgate

    Sounds like it might be.

    Next step would be to load a plain FreeBSD install on there and see if you can get the serial console to work. If it doesn't work on a stock FreeBSD install either, you can then file a PR with FreeBSD to see if it can be fixed upstream.



  • I had switched back to my Alix machine after my last posting and left the case of my Jetway machine open to be ready for further testing. After almost two weeks without further activity in this thread I've decided to live without a working serial console. Yesterday I switched back to the Jetway box to get more experience about stability based on a long term usage when I suddenly saw new responses.

    Next step would be to load a plain FreeBSD install on there and see if you can get the serial console to work. If it doesn't work on a stock FreeBSD install either, you can then file a PR with FreeBSD to see if it can be fixed upstream.

    Just to get the above information right: Would it be helpful to install FreeBSD on the Jetway machine or did you more address the D2500CC board? Which version of FreeBDS should be used - I assume 9.0, although pfSense 2.1 is based on 8.3. Or do you even think of 8.1? To minimize testing efforts I would like to leave my current 2.0.1_nanobsd_vga install on a 8GB SSD untouched and test FreeBSD on a regular harddisk. Unfortunately, I currently don't have one left, but could get one organized within some days. I've no experience with stock FreeBSD so far but a quick check of its homepage revealed that installation should not differ that much from a full pfSense install. Could you please explain in more detail what you mean with

    … you can then file a PR with FreeBSD to see if it can be fixed upstream

    May be it' worth to mention that the serial console works without problems with Linux on this board: Grub2 can be remotely controlled over the serial line, kernel messages are being emitted to it and finally init starts agetty for serial logins.

    Peter


Locked