What is equivalant of wput for pfSense 2.0x?



  • Hi everyone,

    Looking for wput equivalent on a pfSense 2.0x. I am trying to test a DSL connection for dropped packets over a period of 1 week by using "fetch" to download every minute and "wput" to upload every minute. But wput is not installed. What would be the alternative? or can you think of any other creative method that would give me stats for dropped packets and other connection stats over a week?

    There are no computers attached to this DSL line yet. I have to have a tool to simulate data upload/download.

    Thanks


  • Netgate Administrator

    You can just install wput.

    pkg_add -r http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/wput.tbz 
    

    Issue a rehash after that.

    Steve



  • Thanks Steve,

    Seems like quiet few other packages are required and I am afraid to download them as it might mess up things. Can you please confirm if it's safe to install all those required dependencies?

    ### > pkg_add -r http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/wput.tbz
    Fetching http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/wput.tbz... Done.
    Fetching http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/All/libgcrypt-1.4.5_1.tbz... Done.
    pkg_add: warning: package 'libgcrypt-1.4.5_1' requires 'gettext-0.18_1', but 'gettext-0.18.1.1' is installed
    pkg_add: warning: package 'libgcrypt-1.4.5_1' requires 'libgpg-error-1.7_1', but 'libgpg-error-1.10' is installed
    pkg_add: warning: package 'wput-0.6.2_2' requires 'pkg-config-0.23_1', but 'pkg-config-0.25_1' is installed
    pkg_add: warning: package 'wput-0.6.2_2' requires 'gettext-0.18_1', but 'gettext-0.18.1.1' is installed
    pkg_add: warning: package 'wput-0.6.2_2' requires 'libgpg-error-1.7_1', but 'libgpg-error-1.10' is installed
    pkg_add: warning: package 'wput-0.6.2_2' requires 'gnutls-2.8.6_1', but 'gnutls-2.12.14' is installed
    


  • Looks more like the version of wput you are trying to install requires older versions of dependencies that you do already have installed. I seriously doubt you could downgrade them without smashing many other hings.

    Maybe you can find a version of wput that was statically built against its dependencies. It would be larger, perhaps much larger, than a build that was dynamically linked.


  • Netgate Administrator

    Is that a 2.0.1 system?
    It's only installed one dependency, the rest are only warnings.
    I've not tried in though.

    Steve



  • Steve,

    That worked thanks. I redid the pkd_add and noticed it says wput is already installed. Time to find an anonymous ftp server for uploads….

    Are there any other ways I can collect stats other than checking the RRD graphs using fetch and wput?

    Thanks again


Log in to reply