Squid3 and Squid Guard Issues



  • PFSense Version:
    2.0.1-RELEASE (amd64)
    FreeBSD 8.1-RELEASE-p6

    squid3 package: beta 3.1.20 pkg 2.0.5_4 platform: 2.0
    squidGuard package: Beta 1.3_1 pkg v.1.9.1 platform: 1.1

    So I've been messing with squid and squidGuard and I keep running into the same issue with PFSense specifically.

    If install squid v3 only, squid works as expected.  No log errors.

    If I install both Squid and squidGuard it fails.  Errors in the log:

    Sep 10 17:01:31 squid[35195]: Bungled (null) line 182: http_reply_access allow all
    Sep 10 17:01:31 php: /pkg_edit.php: The command '/usr/local/sbin/squid -k reconfigure -f /usr/local/etc/squid/squid.conf' returned exit code '1', the output was '2012/09/10 17:01:31| parseConfigFile: squid.conf:5 unrecognized: 'dns_v4_first' 2012/09/10 17:01:31| parseConfigFile: squid.conf:9 unrecognized: 'error_default_language' 2012/09/10 17:01:31| parseConfigFile: squid.conf:16 unrecognized: 'sslcrtd_children' 2012/09/10 17:01:31| ACL name 'all' not defined! FATAL: Bungled (null) line 182: http_reply_access allow all Squid Cache (Version 2.7.STABLE9): Terminated abnormally.'

    Now I went through all the lines with the errors and took care of the error but this error shows up no matter what: squid[35195]: Bungled (null) line 182: http_reply_access allow all
    I can't find any entry that represents that error in any of the conf files for squid or squidguard.  I went as far as removing the confs pfsense created and replaced it with known basic working squid/squidguard configs from another server I have running.  I still get that error.

    Now the odd thing is when I remove squidguard, it screws up squid, it even goes as far as removing squid from /usr/local/sbin/squid.

    So what is SquidGuard doing to fubar squid?

    Any help would be great.  TIA.



  • Ok.  So I think I figured out the issue.

    So when I install squidguard it's actually installing Squid 2.7, thus replacing my Squid3 install.

    No SquidGuard installed:

    /usr/local/sbin/squid -v
    Squid Cache: Version 3.1.20

    With SquidGuard installed:
    Squid Cache: Version 2.7.STABLE9

    How do I get squidGuard to not require the 2.7 dependency?  To my knowledge 1.4 works with Squid3.



  • Reinstall squid3 after squidguard install. Squidguard package to pfsense is compiled to depend on squid2.

    After getting squid3 running with squidguard, check dnsv4first dns option on gui to prevent some https issues.



  • I had tried that before and it didn't quite take.

    What I've ended up doing is do what you said, install everything, then I removed squid and then I went in via the CLI and removed and squid remnants(like the binary in /usr/local/sbin/squid still existed even after the uninstall).  Once I purged everything out then I installed squid3 again and it seems to take.

    Even with this work around it would seem to be a glitch the packaging system for SquidGuard.  It would be nice if there was a way to do it the correct way versus this workaround way.



  • Hi,

    Having the same problems as described above, and have tried uninstalling both packages and the installing squidguard first and afterwards squid3….

    Now I'm at a point where the squid3 service will start Again (which it wouldn't before) but the squidguard package won't. System is running 2.02-RELEASE

    Any suggestions?

    Regards,
    Anders



  • Ok, so got a Little further… Removed and installed both packages on both CARP nodes, which seems to have fixed something...

    Have 2 issues left now:

    • When attempting to enable XMLRPC sync this error is thrown: Warning: Invalid argument supplied for foreach() in /usr/local/www/pkg_edit.php on line 423

    • When trying to open til Blacklist pane (Services\Proxy filter\Blacklist) I get this error; Parse error: syntax error, unexpected $end in /usr/local/www/squidGuard/squidguard_blacklist.php on line 102

    Any ideas?

    //Anders



  • @Sup3rior:

    Any ideas?

    Reinstall XML.



  • @dvserg:

    Reinstall XML.

    Didn't fix anything unfortunately…



  • @Sup3rior:

    @dvserg:

    Reinstall XML.

    Didn't fix anything unfortunately…

    Try 1-2 hours later, when github will apply the latest commit.



  • @dvserg:

    Try 1-2 hours later, while github applyed the last comit.

    Have completely removed both packages, and will install them again tomorrow… I'll get back with how it goes...



  • I have been looking at these 2 packages recently too…

    To cut a very long story short, as marcelloc says:

    @marcelloc:

    Reinstall squid3 after squidguard install. Squidguard package to pfsense is compiled to depend on squid2.

    After getting squid3 running with squidguard, check dnsv4first dns option on gui to prevent some https issues.

    What doesn't help, is that the pfSense wiki says to do it the "wrong" way around:
    http://doc.pfsense.org/index.php/SquidGuard_package

    ::)

    Anyway, now that I've found this thread (and a couple others where marcelloc says the same thing), it's all working for me (at last!)



  • Have you tried upgrading to PfSense 2.1 Beta?

    I get a couple errors in the log but Squid 3.1 Beta and SquidGuard load and work well.



  • @T-Monster:

    I have been looking at these 2 packages recently too…

    To cut a very long story short, as marcelloc says:

    @marcelloc:

    Reinstall squid3 after squidguard install. Squidguard package to pfsense is compiled to depend on squid2.

    After getting squid3 running with squidguard, check dnsv4first dns option on gui to prevent some https issues.

    What doesn't help, is that the pfSense wiki says to do it the "wrong" way around:
    http://doc.pfsense.org/index.php/SquidGuard_package

    ::)

    Anyway, now that I've found this thread (and a couple others where marcelloc says the same thing), it's all working for me (at last!)

    It is not the wrong way around - it depends on the version of squid and the version of pfsense.
    I updated the wiki so hopefully this will help others in the future.


Log in to reply