DOCSIS 3.0 Bridging?



  • I'm in the process of setting up a NetGate appliance with pfSense 2.0.1 on it.  I have 2 WAN's - one DSL and one cable.  I plan to have them set up in fail-over mode but to send certain types of traffic to one versus the other as long as both are available.

    I set my DSL modem up in bridge mode, and it seems to be quite happy that way.  I'm wondering if it's even possible to do the same with my DOCSIS 3.0 cable modem (by Zoom).  Right now, it's running with a NAT.  So, I essentially have 2 firewalls to contend with.  Is there some reason why it is advisable to run the cable modem in NAT vs. Bridge mode?  Is a bridge even possible?

    Thanks,
    Dave



  • Bridge is the default and only option with most cable modems. Many business class modems are different, you have the ability to run NAT and have a public IP only on the modem, but it's also always an option to have a public IP subnet inside the modem. And that's the option you always want when you're using a real firewall and not just the modem's NAT. You'll have to check with your ISP to see what your options are there. Tell them you have a firewall plugged into the modem and you need your public IP assigned to that.



  • Comcast or other??



  • Comcast cable.  I am using a Zoom Docsis 3.0 Modem/Router combo on it right now.  It's not clear at all how to turn off all of the router/firewall goop on the device.  Then, of course, I'm not sure how to configure it in pfSense.  I assume it's not static, but not exactly DHCP, either?

    Thanks for the replies!
    Dave



  • With Comcast business you're assigned at least a /30 subnet if not a /29 on the inside of the modem, which is what you use on the firewall's WAN.



  • No, this is residential Comcast.  :)  I did try to get business class, but it was not available.  I finally found the CD that came with the modem.  Hopefully, the manual on it will have some answers about bridging the modem.  The rest, I may have to contact Comcast to find out, if they will even tell me.



  • Can you tell us what model of Zoom cable modem you have.  I have a Docsis 3 Zoom Cable Modem, and it doesn't do NAT by default.


  • Rebel Alliance Global Moderator

    If its called a cable "modem" it wouldn't be doing nat - they do have "gateway" cable devices that would.  But normally a cable modem does not do any nat.  As already requested what is the model number of the zoom device you have?



  • It is the Zoom 5350 Cable Modem/Router.  It does do NAT by default.  There is an option to disable the firewall and DHCP server, but I haven't found any options to disable NAT.  I've sent a question to Zoom to ask about it.  My suspicion is that I'm going to have to get a new modem-only device that will pass the public IP on to pfSense for me.  The user's manual on the CD was absolutely no help either.  It was basically a tour of the menus.


  • Rebel Alliance Global Moderator

    What does this do? ;)




  • Bah!  I must be blind.  Somehow, I completely missed that option.  I'll give it a try when I get back to the house.
    Thanks!



  • I tried disabling NAT.  That simply made things unusable.  Had to reset the device to get it working again.

    In the meantime, I received a reply from Zoom.  Without admitting that the modem/router can't be configured as a bridge, I was advised to purchase just a "modem" that would act in bridge mode.  So, I did that.  I picked up a Cisco DPC3008.  After a bit of fiddling and a couple of calls to Comcast, I've got it working with my NetGate pfSense router.

    Thanks for all the input.  I'm sure you'll be hearing more from me as I try to figure out how to configure the firewall, port forwarding and failover stuff.  I'll try not to be a pest, though.

    Cheers,
    Dave


Locked