Round Robin is lopsided



  • My problem is very similar to what is described in this thread: http://forum.pfsense.org/index.php?topic=39600.0

    My version is: 2.0.1-RELEASE (i386)  I did an in place upgrade from 1.2.3

    I have tried all the suggestions listed in the thread.  I have only two rules on LAN in an attempt to trouble shoot the issue; the anti lock out and the rule to use the gateway group as defined under routing. I removed all other rules.  Doing so has not changed the outcome. The gateways are defined on the same tier in the group. And also are weighted equally.  Both WAN connections are identical in speed, both are 2.5mb DSL, NAT and any other services are disabled on the DSL modems.  Pfsense does have Squid installed in transparent mode with tcp_outgoing_address 127.0.0.1 set as one of the options.  It would appear that the bulk of traffic is biased to the WAN interface.  Some traffic does cross WAN2, but usually only kilobits as opposed to megabits with an occasional spike into the mbit range.  Previous to the upgrade I could speed test and show 5mbit combined, do the IP tests and get one or the other WAN IP. Now I only show 2.5mbit on speed test and always the same IP when attempting to view IP through google or otherwise.  Route table has as first entry the WAN as the default gateway if that matters, as it would seem to be usurping the policy at this point.  What else can I check or change or look for?



  • You may need to create a floating rule which pipes traffic into the load balancing gateway. - See http://forum.pfsense.org/index.php/topic,38882.0.html for good instructions and screenshots.


Locked