Load Balance with sticky sessions



  • I had some trouble getting this to work in pfSense 2.01 (amd64) and finally found a comment somewhere that mentioned a reboot was required after enabling sticky sessions for load balancing.

    To anyone in the future troubleshooting sticky sessions with your load balancing, i hope this may help: reboot your pfSense after enabling sticky on System - Advanced - Miscellaneous - Load Balancing - Use Sticky Connections



  • I am also facing problems with sticky. I read in previous post that this is not really working. Anyone know when they will fix this issue?


  • Netgate Administrator

    @abubin:

    Anyone know when they will fix this issue?

    Is there an outstanding bug report on it? If not then it's unlikely to be looked at anytime soon.

    What problems are you having? What is your setup? etc?

    Steve



  • since this problem has been mentioned by many in this forum and in some blog sites, I assumed that it is and existing feature that is not fully implemented.

    I have 2 wan connections that I setup as tier 1 group.

    I can see the IPs getting switched very quickly between the two wans. My users are complaining this is causing them problem with some sites that track login with ips.

    I do not know what is there to check. Since the multi-wan is working fine. It's the sticky IPs that doesn't seems to work.


  • Netgate Administrator

    I admit that it's a while since I tried sticky connections but last time I did it didn't seem to make much difference. And, yes, I've also seen many posts where other have seem similar results. However I'm not sure whether this is a bug or just that 'sticky connections' doesn't do what you think it should.

    Either way I have removed these issues by just adding a policy based rule to route traffic to websites that don't play nicely via a single WAN. You could also route it via a failover group if your WANs are not too reliable. Most websites these days seem able cope with load balancing, even those that previously had trouble.

    Steve



  • thanks for the explanation. Seems like a lot of people who had similar problem had been using firewall policy to solve it.

    I have successfully re-routed the problematic websites to using one specified WAN instead. So far it's working fine.  Appreciate your reply on this.



  • my thought may wrong is  sticky sessions means by static ip? did any one try to add the loadbalacing like this ….

    I am using 5 static ips  and pppoe connection . but static ips are pointing to other services . I never feel problem on it


  • Netgate Administrator

    @rakeshvijayan:

    my thought may wrong is  sticky sessions means by static ip?

    Nope. Sticky connections refers to a setting in System: Advanced: Misc (see attached pic). It is supposed to set the load balancer to use the same WAN for outgoing connections to the same server.

    Hmm, re-reading this now it looks like it could be incoming load balancing. That would explain why it seems to have no effect.  ::)

    Steve




  • @stephenw10:

    @rakeshvijayan:

    my thought may wrong is  sticky sessions means by static ip?

    Nope. Sticky connections refers to a setting in System: Advanced: Misc (see attached pic). It is supposed to set the load balancer to use the same WAN for outgoing connections to the same server.

    Hmm, re-reading this now it looks like it could be incoming load balancing. That would explain why it seems to have no effect.  ::)

    Steve

    Well, sticky connections should do as described in the context. As far as I am concern, it did not do what it promised. So I would say either it's a bug or incomplete implementation.


Log in to reply