Cache Windows update trouble



  • Hello. I'm very new at this pfsense so forgive me if I'm not 1337 :) I have this configuration in my squid preferences:

    refresh_pattern -i .microsoft.com/..(cab|exe|msi|msp|msu|msf|asf|wm[v|a]|dat|zip|dll) 259200 100% 259200 override-expire override-lastmod reload-into-ims ignore-reload ignore-no-cache ignore-private;refresh_pattern -i .windowsupdate.com/..(cab|exe|msi|msp|msu|msf|asf|wm[v|a]|dat|zip|dll) 259200 100% 259200 override-expire override-lastmod reload-into-ims ignore-reload ignore-no-cache ignore-private;range_offset_limit 100 MB;quick_abort_pct 60;

    I can see in the squid folder that it does cache the files, however when updating new computers they don't seem to read from the cache. What am I doing wrong??

    Thanks for any advice

    /Regards Kriv0



  • I am using this code:

    
    refresh_pattern -i .*microsoft\.com/.*\.(exe|zip|rar|cab|tar|bz|bz2|msi|gz|msp) 259200 100% 259200 override-expire override-lastmod reload-into-ims ignore-reload ignore-no-cache ignore-private;
    refresh_pattern -i .*windowsupdate\.com/.*\.(exe|zip|rar|cab|tar|bz|bz2|msi|gz|msp) 259200 100% 259200 override-expire override-lastmod reload-into-ims ignore-reload ignore-no-cache ignore-private;
    
    

    Perhaps you should add "windowsupdate.com"

    And you must allow in squid cach mngt that big files up to ~300MB for patches or up to 1.000MB for service packs are allowed to be cached on your HDD.
    So your "Hard disk cache size" must be big enough and your "Maximum object size".



  • Thanks for the reply. I think that windowsupdate.com is in there, but the filesize was a bit low I guess. I had it at 1024… I changed that so will see what happens. There is an option for offline mode. What will happen if I check that box?

    /Regards Kriv0



  • Sorry I missed the line about windowsupdate.com ;)

    Don't know what happens when you use "offline_mode" - never used it.
    search squid-cache.org for more information.


Locked