Port forward for owncloud help



  • I once upon a time had my pfsense box forwarding port 80 to my webserver, my webserver went down and a few months later I fixed it. Now I cannot for the life of me get pfsense to allow outside traffic to my webserver ..

    I am using pfsense version 2.0.1 386 version, and attemtping to use owncloud installed on ubuntu server 12.

    I can access my webgui for pfsense from outside my network via my dyndns address over port 443 with no problem.
    I can access my owncloud via 192.168.1.12/owncloud or userver/owncloud ( userver is the name of the ubutnu box ).

    when I try to access my owncloud from outside my lan I can see it in the firwall getting blocked, I allow it to pass via easy rule pass and then I change the destination address to the server "192.168.1.12"

    so my easy created rule in my nat looks like this

    interface > wan
    protocol > tcp
    source > any
    source port rage > http, http
    Destination > single host or alias "192.168.1.12"
    destination port range > http, http
    redirect target IP > 192.168.1.12
    redirect target port > http "80"
    description > n/a
    nat reflection > use system default.
    filter rule > create new associated filter rule ..

    the rule is successfully created under firewall > rules and is on the bottom? I can not move it to the top because RFC 1918 networks and reserved/not assigned by IANA are unmoveable. Not sure if this is a problem or not.

    The only 2 rules I have above this are to pass traffic 443 to the pfsense box itself and to allow ssh traffic over port 22.

    I am unsure of what I am doing wrong, more than likely it isd right in front of me, but I have been playing with this for 2 days now with no luck :(

    Thank you in advance appreciate the help :)



  • After days of working on this I found a guide I understood .. http://www.packtpub.com/article/pfsense-configuring-nat-firewall-rules they have a sample webserver setup using pfsense and exactlly what I was trying to do. Hope it helps someone.

    I had a lan address in the destination box, when it should have been "wan address" works perfect now.

    ** Solved **


Locked