Booting from USB CD fixed?



  • Someone recently posted that they had installed via USB CD-ROM, which has previously not worked in FreeBSD. My initial thought was that the unit he had was doing some sort of BIOS trick to allow this.
    But I just Installed both pfSense 1.2-beta1 and FreeBSD 6.2 on an Armada E500 (laptop with CD off the USB to be hot-swapable) that I had tried to install 6.1 and some version of PC-BSD on before. (and failed).
    Looks like this long-standing bug may have been fixed in 6.2. It's at least working for me on a machine that didn't work before…



  • Very interesting.

    runs off to test  ;D



  • Nope, still hangs on boot for me. That specific laptop and drive may not look/act like USB to the OS.



  • Drat. Had my hopes up after this machine worked and the other report of installing via USB drive. I didn't have a stand alone USB cdrom handy. This particular machine used to boot the CD, load the installer, then report no cd found when it tried to start copying files. I went back and checked the devices, and it doesn't actually look like the CD is off the USB bus. There are a few Dell laptops like that around here- I guess I got mixed up as to why each laptop wouldn't load FreeBSD. At least I have a FreeBSD laptop to play with now.



  • Well, I managed to get pfSense installed via a USB CD-ROM and I've just seen a post on the freebsd-stable list saying that while the FreeBSD bootloader generally doesn't cope with USB devices, it seems to be hardware dependant (ie, on some combinations of motherboard and USB device it just works).

    So, I think the answer is - if it works for you make sure you note the combination you've used in case you need to re-install :)



  • I am working to switch our CD boot loader to grub.  So far its been difficult so no promises, but I am atleast trying to do so.


Log in to reply