Snort 2.9.2.3 pkg v. 2.5.1 - 'ssl_state' error - unable to start



  • Hey everyone,

    I just upgraded to the new package.  Had to completely redo my config file since the upgrade didn't preserve any of my settings.  I am now getting the following error:

    snort[49863]: FATAL ERROR: /usr/local/etc/snort/snort_21470_bge0/rules/snort_exploit.rules(362) Unknown rule option: 'ssl_state'.

    I played with enabling and disabling certain categories, but they all pretty much use the "ssl_state" option. I have to pretty much disable all categories to get rid of this message and get snort to start.  I do have the SSL Data preprocessor enabled.  (I tried it both ways.)

    Any ideas?



  • I have exactly the same problem - did you find a solution to this?


Log in to reply