Configure squid ldap Active directory



  • Hello,

    I'm doing some tests with a pfsense 2.0.1-RELEASE (amd64).

    I try to activate the authentication proxy with Active Directory, but it still fails. I have reviewed the information post and the internet and I can not make it work.

    I installed it squid3 package. The proxy I have not configured transparently. The authentication configuration is this where the domain is xxxxx.local

    LDAP Authentication method
    Authentication server 172.30.40.11
    Authentication server port 389
    Authentication prompt            blank
    Authentication Processes 2
    Authentication TTL 60
    Require authentication for unrestricted hosts unmarked
    That do not need authentication Subnets      blank

    LDAP version 3
    LDAP server user DN cn = administrator, cn = users, dc = xxxxx, dc = local
    LDAP password xxxxxxxxxx
    LDAP based domain dc = xxxxx, dc = local
    LDAP username DN attribute uid
    LDAP search filter sAMAccountName =% s

    It tells the browser the proxy, but I do try to log on credentials error constantly. It's as if he saw active directory users.

    Can you help?

    Thank you.



  • @didac:

    I installed it squid3 package. The proxy I have not configured transparently.

    Authentication does not work with transparent proxy.



  • I have not configured in transparent mode



  • Sorry, I've missed the "not"…

    Can you tcpdump some packages to check if pfsense is sending packages to your ldap?

    These days a saw a dns problem that was slowing down ldap communication..


Locked