Both carp systems think they're master on 1/2 interfaces



  • I'm having a problem getting CARP to work properly. I followed the CARP TUT to a tee, repeatedly.

    I have a DLINK router on the WAN side of my routers so I can turn my one public static into a CARP cluster, as per the various diagrams though the forum. I will be adding a 2nd WAN on a OPT interface in next week which will have a /29 subnet so I can use public addresses right on the NICs.

    WAN subnet 192.168.2.0 /24
    LAN subnet 192.168.0.0 /24

    Basically my problem is this… on the LAN interface Both partners will decide they are master, but on the WAN only the primary will be master.

    The CARP sync is being done though firewire, which all seems to be running smoothly, rules and VIP setup sync. I tried moving the CARP to the LAN temporary and the same problem exists. There are no error messages in the logs related to the firewire.

    I've created all rules and VIP's from the Primary box.

    I do get some hints from the system log

    kernel: arp_rtrequest: bad gateway 192.168.2.10 (!AF_LINK)                      <<wan carp="" vip<br="">kernel: arp_rtrequest: bad gateway 192.168.0.6 (!AF_LINK)                      < <lan carp="" vip<br=""></lan></wan>



  • Hi,

    I've seen the same problem here but I actually wasn't able to fix it. After reconfiguring/reinstalling both systems it seemed solved for me but I would really like a solution for this.

    bye



  • I think the problem was mostly a bad network connection.

    However I am having the problem now where the secondary box keeps taking over master role and the primary releases and runs as backup.

    I keep going to the Firewall >>VIP >> Carp settings,  on the master machine and hitting save.

    I think that should reassert its role as master correct…? If not, how do you?


Log in to reply