Squid not caching



  • I have installed 2.0.1-RELEASE (i386) on an Intel Atom CPU D525 @ 1.80GHz with 2GB of RAM. I have configured squid as a caching server using the recommend settings.

    Hard disk cache size: 3000
    Hard disk cache system: UFS
    Hard disk cache location: /var/squid/cache
    Memory cache size: 512
    Minimum object size: 0
    Maximum object size: 4
    Maximum object size in RAM: 32
    Level 1 subdirectories: 16
    Memory replacement policy: Heap GDSF
    Cache replacement policy: Heap LFUDA
    Low-water-mark in %: 90
    High-water-mark in %: 94

    Using this site http://www.lagado.com/tools/cache-test I run the test cache. As instructed I load the page dump all my firefox Cache and than reload the page, each time the page serial number number changes; which indicates that no caching is enabled. Testing the site using the page age method also suggest that squid is not caching client content. Also in the three weeks I have been using this setup the disk usage is still at 0%.

    How would one begin to troubleshoot this? any ideas what's going on? This is my first pfsense setup.

    Thanks,
    -Tim



  • Increase the object size. 4kb is not really big. If an object is bigger than this size it will not be cached.



  • @Nachtfalke:

    Increase the object size. 4kb is not really big. If an object is bigger than this size it will not be cached.

    Nachtfalke,

    Great! thanks for the help, the cache test is showing that content is now being cached after setting "Maximum object size" to 320010 KB. Thanks again for the help.



  • @time4e:

    @Nachtfalke:

    Increase the object size. 4kb is not really big. If an object is bigger than this size it will not be cached.

    setting "Maximum object size" to 320010 KB.

    Is that a typo or did you really set it to over 300 megabytes?



  • @kyronax:

    @time4e:

    @Nachtfalke:

    Increase the object size. 4kb is not really big. If an object is bigger than this size it will not be cached.

    setting "Maximum object size" to 320010 KB.

    Is that a typo or did you really set it to over 300 megabytes?

    That's not really a problem - if you have enough space. I set it to 1GB - because I want to cache windows updates, service packs and so on.



  • @Nachtfalke:

    @kyronax:

    @time4e:

    @Nachtfalke:

    Increase the object size. 4kb is not really big. If an object is bigger than this size it will not be cached.

    setting "Maximum object size" to 320010 KB.

    Is that a typo or did you really set it to over 300 megabytes?

    That's not really a problem - if you have enough space. I set it to 1GB - because I want to cache windows updates, service packs and so on.

    Ah okay, makes sense.



  • But there is a difference between "Maximum object size in RAM" and "Maximum object size".
    Maximum object size in RAM should not be so high but for caching on HDD this is possible.



  • @nachtfalke - how to write on maximum object size (1GB) in kb ? Newbie here.



  • @jykhies:

    @nachtfalke - how to write on maximum object size (1GB) in kb ? Newbie here.

    Don't worry about some bytes or kilobytes. Just write 1000000 or 1024000. :)



  • tnx a lot Nachtfalke - my squid is not working too. :) newbie. HAPPY NEW YEAR TO YOU and to all !


Locked