Seeing a lot of, "500 - Internal Server Error"



  • I am seeing a lot of 500 - Internal Server Error
    I am currently using the developmental version and toying a lot with the GUI (not guts) so it might be due to that but just wanted to give heads up.


  • Netgate Administrator

    Anything in the system logs? Out of memory?
    This should be in the 2.1 subforum really.

    Steve


  • Rebel Alliance Developer Netgate

    What packages are you using?

    I have a ton of 2.1 boxes (real and virtual) and have not seen this happen.



  • I am getting this on the pfblocker widget, noting in the logs point to a problem, it was working fine for about a day or so.




  • I am seeing the same thing with the pfblocker widget. Using packages:

    bandwidthd, ntop, Open-VM-tools, pfblocker, shellcmd, snort, tftp.

    Doing a pf -sf

    shows the rules as in pf.



  • @arad85:

    I am seeing the same thing with the pfblocker widget. Using packages:

    bandwidthd, ntop, Open-VM-tools, pfblocker, shellcmd, snort, tftp.

    Doing a pf -sf

    shows the rules as in pf.

    /var/log/lighttpd.error.log shows:

    
    2012-11-29 18:52:41: (mod_fastcgi.c.2543) unexpected end-of-file (perhaps the fastcgi process died): pid: 4862 socket: unix:/tmp/php-fastcgi.socket-1
    2012-11-29 18:52:41: (mod_fastcgi.c.3329) response not received, request sent: 1105 on socket: unix:/tmp/php-fastcgi.socket-1 for /widgets/widgets/pfBlocker.widget.php?getupdatestatus=yes, closing connection
    2012-11-29 18:52:41: (mod_fastcgi.c.1732) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2012-11-29 18:52:41: (mod_fastcgi.c.3002) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
    
    

    when I get the 500 - server error.


  • Rebel Alliance Developer Netgate

    So it's a pfBlocker widget problem (perhaps it uses "exit" when it should use "return"). You'll have better luck getting a fix in the packages forum with a more accurate subject.



  • OK, thanks. May take a look at it myself first.



  • I am also getting this error, running 2.0.2-RELEASE (amd64)

    is there a fix?


  • Rebel Alliance Developer Netgate

    There are fixes that happened after 2.0.2, there will be a 2.0.3 shortly.
    2.1 should be OK now also.


Locked