Route add default -iface em0



  • Hi,
    i wanted pfsense to get the public address but pppoe doesn't work with my ISP , so i use an ethernet modem in half-bridge mode.

    here a scheme: device(address-how.it.is.set)

    modem(192.168.0.1-static)(public.ip.addr.ess-dhcp)
      |
      |
      |
    pfsensewan(192.168.0.4-alias)(public.ip.addr.ess-dhcp)
    pfsenselan(192.168.1.1-static)
      |
      |
      |
    LAN(192.168.1.2-254-DHCP)

    I got internet access from lan but not from pfsense itself. this resulted in long stalls in the web configurator and in the impossibility to use the dns forwarder.
    I managed to get everything working by setting the wan interface as default route, instead of the modem ip address, using these commands:

    route del default
    route del 8.8.8.8
    route del 8.8.4.4
    route add default -iface em0
    

    The problem is that it keeps resetting to default settings at every wan dhcp renew.

    these are  the working routes

    Destination        Gateway            Flags    Refs      Use  Netif Expire
    default            28:36:23:f4:e0:f3  US          0    77584    em0
    public.ip.addr.ess/32  link#1             U           0        0    em0
    127.0.0.1          link#6             UH          0    65195    lo0
    192.168.0.0/24     link#1             U           0     2733    em0
    192.168.0.4        127.0.0.1          UHS         0        0    lo0
    192.168.1.0/24     link#2             U           0 243431601    em1
    

    and these are the setting it keeps reverting to:

    Destination        Gateway            Flags    Refs      Use  Netif Expire
    default            192.168.0.1  US          0    77584    em0
    8.8.4.4            192.168.0.1        UGHS        0      145    em0
    8.8.8.8            192.168.0.1        UGHS        0      192    em0
    public.ip.addr.ess/32  link#1             U           0        0    em0
    127.0.0.1          link#6             UH          0    65195    lo0
    192.168.0.0/24     link#1             U           0     2733    em0
    192.168.0.4        127.0.0.1          UHS         0        0    lo0
    192.168.1.0/24     link#2             U           0 243431601    em1
    

    8.8.8.8 and 8.8.4.4 are the dns addresses

    (EDIT) I'm using 2.0.1-RELEASE (amd64)

    There is a way to override this automatic setting?
    thanks


Log in to reply