Igmpproxy running, iptvplayer - blank screen



  • pfSense version:
    2.0.1-RELEASE (i386)
    built on Mon Dec 12 17:53:52 EST 2011
    FreeBSD 8.1-RELEASE

    Trying to get my IPTV goin' on pfSense. A year ago it was perfectly running on my gentoo box.
    There is a custom IPTV player my ISP provides. Though, wireshark did his job and now I can view all channels, while connected directly, via VLC on my laptop. I made m3u playlist for those:

    #EXTINF:0,LRT
    udp://@233.136.41.12:1234
    #EXTINF:0,TV3
    udp://@233.136.41.39:1234
    #EXTINF:0,Lietuvos Ryto TV
    udp://@233.136.41.15:1234
    #EXTINF:0,TV6
    udp://@233.136.41.38:1234
    #EXTINF:0,BTV
    udp://@233.136.41.20:1234
    #EXTINF:0,LRT Kultura
    udp://@233.136.41.31:1234
    #EXTINF:0,Penki TV
    udp://@239.255.13.185:1234
    #EXTINF:0,Zvaigdze
    udp://@239.255.12.42:1234
    #EXTINF:0,Anonsai
    udp://@239.255.13.182:1234

    What i did on my pfSense box to pass-through multicast:

    • Destroyed my bridge with wireless card, so that I knew its not the case of misbehavior
    • Reset pfSense to standart settings
    • Enabled rule in System -> Advanced -> Firewall/NAT (Disables the PF scrubbing option which can sometimes interfere with NFS and PPTP traffic.)
    • Added Upstream (WAN) 239.255.12.0/24, 224.0.0.0/4 to igmproxy config
    • Added Downstream (LAN) 192.168.0.0/24 to igmpproxy config
    • Firewall -> Rules -> WAN added    UDP * * 224.0.0.0/4 * * none
                                                      UDP * * 239.255.12.0/24 * * none
    • Firewall -> Rules -> LAN added    IGMP LAN net * 224.0.0.0/4 * * none
                                                      IGMP LAN net * 239.255.12.0/24 * * none
        Both with (This allows packets with IP options to pass. Otherwise they are blocked by default. This is usually only seen with multicast traffic) ticked.
        Put both rules above existing.

    I doubt that rules with 239.255.12.0/24 are necessary, but they don't conflict anyways.
    Any help would be appreciated.


Log in to reply