Not able to make Limiters work, please help…



  • Hello everybody… i am getting sick with Traffic Shaper!!! for sure i am doing something wrong but i do not know what!!!

    I am trying to limit the overall bandwith Pfsense can use in the WAN interface, because if i use more than 100Mbps, the carrier charges an extra fee.

    It seems i am stuck in here, please help!!!!! i have tried with both Queues and limiters with no luck in any case...  this is what i did with limiters:
    (i re-use a previous owesomo post with his permission)

    _Go to the Firewall>>>Traffic Shaper option

    Create a limiter, name it "in", type 100Mpbs. Save it and enable it.

    Create another limiter, name it "out", type 100Mbps. Save it and enable it.

    Go to firewall>>>Rules>>>Floating

    Create a new rule. Action Pass, Traffic type ANY, select WAN interface, direction IN, source ANY, destination ANY, scroll down click advanced next to in/out, set the first to in, the second to out.

    Save and Apply…._

    But it does not work… what am i doing wrong??? i have tried reseting states, Fw reboote, etc... no luck  :(

    thanks in advance to all!!

    Pedreter.



  • I tested this with my lab setup and you cannot use floating rules for limiters. It only worked on the interface originating the traffic. I would use shaper for better control and traffic prioritization. Just my $0.02.



  • @podilarius:

    I tested this with my lab setup and you cannot use floating rules for limiters. It only worked on the interface originating the traffic. I would use shaper for better control and traffic prioritization. Just my $0.02.

    Thanks a lot for you reply…

    but then, is there any simple way to limit all traffic as a whole with just one rule? or the only way is going rule by rule setting a queue?

    Thanks again!

    Pedreter.



  • In traffic shaping you set the 2 parent queues with the overall bandwidth requirement wan is outbound and LAN is inbound. You can just set that up if you like. You don't have to use any othe queues or rules if you like. Just run the wizard and give it you Internet speeds and don't choose any other options.



  • @podilarius:

    In traffic shaping you set the 2 parent queues with the overall bandwidth requirement wan is outbound and LAN is inbound. You can just set that up if you like. You don't have to use any othe queues or rules if you like. Just run the wizard and give it you Internet speeds and don't choose any other options.

    Hi Again…

    i did what you suggedted first and it worked!!!! THANKS!!!! just using a LAN rule it controls IN and OU traffic...

    i have tried you you have suggsted now but running just the wizard and adjusting LAN values (not properly set by the wizard) it does not work... are you sure i do not have to set any rule to match traffic?



  • It should just create a default queue. The default queues don't need a rule assigned to it. All traffic we be applied to that queue. Mine just happens to be qP2P, but if you don't enable that, it should create one called Default.


Log in to reply