LAGG child interfaces running at wrong speed?



  • Having just physically installed my pfsense machine in its production environment after several months of testing and twiddling rules, have spotted that the speed is not what it should be.

    On the LAN side, I have a LAGG interface, consisting of two Intel Pro/1000 interfaces, connected to gigabit interfaces in a stacked pair of Cisco 3750s, configured as an  LACP Etherchannel at both ends.  The problem is that the two child interfaces are reporting as having negotiated at 100Mb/s.  Both ends are configured to autonegotiate speed, and this was working at 2*gigabit previously.

    Any ideas?  I know that I can try forcing one end to gigabit, but if it can't autonegotiate correctly, that suggests something is wrong.  Also, now the firewall is routing real traffic (even if it is mostly just students browsing facebook!) I'm reluctant to do anything disruptive just to see what happens…

    Are there any known issues with speed negotiation via link aggregation?

    Ta,
    Steve.



  • Also a follow-on question…  Is there actually any way to set the speed of the child interfaces of a LAGG interface?  There is no way via the LAGG tab in interfaces, only to choose which interfaces are part of the aggregated link.  And the advanced options for the LAGG interface itself only allows 'autoselect', which makes sense as the aggregate is the sum of the child interfaces.

    Is LACP the preferred way to configure this when connecting to a Cisco switch?  I also tried configuring it to 'fec' - documented as the static Cisco Etherchannel option, with the Cisco end configured as 'On (no LACP)', but with that setup it timed out without detecting a link at all.
    Is anyone else actually using link aggregation to a Cisco Etherchannel portgroup?

    This is in 2.0.1 by the way, as I forgot to specify in the previous post..

    Cheers,
    Steve.


  • Netgate Administrator

    There is a similar discussion here:
    http://forum.pfsense.org/index.php/topic,50444.0.html
    In that case it's setting MTU rather than connection speed. It ended in a horrible hack.  ;)

    Also here: http://forum.pfsense.org/index.php/topic,50563.0.html

    Steve


Log in to reply