[Resolvido] autenticação "transparente" com pfsense + squid + active directory sem funcionar os bloqueios



  • Boa tarde galera.
    Estou um tempo sumido do forum.
    Mas agora estou de volta, mudei de empresa e estou colocando o PF no lugar do Iptalbles.
    Estou seguindo esse tuto mas estou com a seguinte dúvida:
    Na cfg do squid em auth settings ei deixo como none?

    Até o momento parece que esta ok.
    Todos os testes via linha de comando estão dando certo.
    Não está aparecendo o popup para quem está no dominio.
    Só que coloquei um site la blacklist do squid e não está bloqueando.

    Eu não segui exatamente os passos aqui do forum fui pegando um pouco de cada lugar.

    Estou com a ultima versão do pfsense e o squid 2.7.9 pkg v.4.3.1 não estou com o squid-guard.

    E coloquei esta linha na cusntom options do squid:
    auth_param ntlm program /usr/local/bin/ntlm_auth –use-cached-creds --helper-protocol=squid-2.5-ntlmssp;auth_param ntlm children 30;auth_param ntlm keep_alive on;auth_param basic program /usr/local/bin/ntlm_auth --helper-protocol=squid-2.5-basic;auth_param basic children 5;auth_param basic realm Squid

    Alguém sabe me dizer o porque que o bloqueio não está funcionando?



  • confere o squid.conf gerado pelo pacote na parte de permissões das acls.



  • achei o problema.
    É que no squid.conf a acl que libera o pessoal autenticado estava vindo antes da que bloqueia, foi só trocar e deu certo.


Log in to reply