WiFi unable to come up - Atheros 9280 - Unable to reset hardware; hal status



  • Hey Guys,

    I'm having issues with the WiFi on my ALIX box… The card is being recognised as a WiFi adapted and i am able to put in a simple config but it will not come "up".

    As you can see bellow dmesg is showing that the device is unable to reset with a hal status error of 3...  I have been searching the internet for a while now and am unable ot come up with anything useful..

    I am only using this card in g mode thus avoiding the N issues. i have provided error lines bellow.

    any help here would be great.

    $ dmesg |grep ath
    ath0: <atheros 9280="">mem 0xe00c0000-0xe00cffff irq 9 at device 12.0 on pci0
    ath0: [ITHREAD]
    ath0: AR9280 mac 128.2 RF5133 phy 13.0
    ath0: unable to reset hardware; hal status 14
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: ath_chan_set: unable to reset channel 1 (2412 MHz, flags 0xa0), hal status 3
    ath0: ath_reset: unable to reset hardware; hal status 3
    ath0: ath_chan_set: unable to reset channel 6 (2437 MHz, flags 0xa0), hal status 3
    ath0: ath_reset: unable to reset hardware; hal status 3
    ath0: ath_chan_set: unable to reset channel 11 (2462 MHz, flags 0xa0), hal status 3
    ath0: ath_chan_set: unable to reset channel 7 (2442 MHz, flags 0xa0), hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: ath_chan_set: unable to reset channel 1 (2412 MHz, flags 0x480), hal status 3
    ath0: ath_reset: unable to reset hardware; hal status 3
    ath0: ath_chan_set: unable to reset channel 6 (2437 MHz, flags 0x480), hal status 3
    ath0: ath_reset: unable to reset hardware; hal status 3
    ath0: ath_chan_set: unable to reset channel 11 (2462 MHz, flags 0x480), hal status 3
    ath0: ath_chan_set: unable to reset channel 7 (2442 MHz, flags 0x480), hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3
    ath0: unable to reset hardware; hal status 3</atheros> 
    
    $ ifconfig -a
    vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:29:66:54
    	inet6 fe80::20d:b9ff:fe29:6654%vr0 prefixlen 64 scopeid 0x1 
    	inet 192.168.1.2 netmask 0xffffff00 broadcast 192.168.1.255
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:29:66:55
    	inet 10.10.6.120 netmask 0xffffff00 broadcast 10.10.6.255
    	inet6 fe80::20d:b9ff:fe29:6655%vr1 prefixlen 64 scopeid 0x2 
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    vr2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:29:66:56
    	inet 10.10.11.200 netmask 0xffffff00 broadcast 10.10.11.255
    	inet6 fe80::20d:b9ff:fe29:6656%vr2 prefixlen 64 scopeid 0x3 
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (none)
    	status: no carrier
    ath0: flags=8803 <up,broadcast,simplex,multicast>metric 0 mtu 2290
    	ether 90:a4:de:c0:49:46
    	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
    	status: running
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    	options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000 
    	inet6 ::1 prefixlen 128 
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6 
    	nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
    	syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    enc0: flags=0<> metric 0 mtu 1536
    ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	ether 90:a4:de:c0:49:46
    	inet6 fe80::92a4:deff:fec0:4946%ath0_wlan0 prefixlen 64 scopeid 0x9 
    	inet 10.10.10.200 netmask 0xffffff00 broadcast 10.10.10.255
    	nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
    	status: no carrier
    	ssid users-hh-das-haus-online channel 7 (2442 MHz 11g)
    	regdomain ETSI country GB indoor ecm authmode WPA2/802.11i
    	privacy MIXED deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit
    	txpower 30 scanvalid 60 pureg protmode OFF burst -apbridge
    	dtimperiod 1 -dfs
    ovpnc1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    	options=80000 <linkstate>inet6 fe80::20d:b9ff:fe29:6654%ovpnc1 prefixlen 64 scopeid 0xa 
    	inet 10.10.0.2 --> 10.10.0.1 netmask 0xffffffff 
    	nd6 options=3 <performnud,accept_rtadv>Opened by PID 51412</performnud,accept_rtadv></linkstate></up,pointopoint,running,multicast></hostap></performnud,accept_rtadv></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></hostap></up,broadcast,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast>
    


  • Hey Guys,

    Just attempted t start from scratch with the config and test each step one by one…

    Iv found that with no authentication the interface dose come up but it dose not broadcast the SSID and i am unable to connect to it manually...


  • Netgate Administrator

    I think this has come up a few times on the forum though I can't remember if there was a solution.  ::)
    Is it a new card? Check that it's seated correctly, easy to overlook.

    Steve

    Edit: struck by autocorrect!



  • hi Stephenw10,

    you are right it has come up a few times but there was nether a fix posted to thread…. -_-

    The card is brand-new but it is from USA as a "set" with the motherboard that I got shipped to the UK... it looked to be in proper antistatic bags though and was well wrapped.
    http://www.ebay.com/itm/ws/eBayISAPI.dll?ViewItem&item=271020438563&ssPageName=ADME:X:RTQ:US:1123

    I have just attempted a reseat and i am seeing the same issue....

    any other suggestions?

    thank you


  • Netgate Administrator

    Ah, I failed to spot how new the card was. You will almost certainly have to use a 2.1 snapshot with that card.

    Steve



  • hey,

    I gave the latest snapshot a go and it didn't work…

    looks like a new wifi card for this thing -_- any suggestions?

    Thank you



  • Please provide more details than "didn't work". What did you do? what did you expect to happen? what actually happened?


Log in to reply