Pfsense with wifi / lan bridge (ip set on bridge) and windows 7



  • Hello dear fellow users,

    I'm seeing a strange behavior, when i reboot pfsense with a wifi/lan bridge, lan ip set on the bridge :
    After every reboot, windows asks to re-identify the Network (Public, Office or Home).

    I'm suspecting the problem is that the mac address of the bridge changes after every reboot, hence windows thinks it's a different Network.

    Do you think i'm right ? and if yes, is there a way to keep the same mac for the bridge between reboots ?

    Regards,
    Stéphane.


  • Netgate Administrator

    Even if the bridge MAC does change the AP MAC should not and that's what Windows uses to identify the wireless network. What wifi hardware are you using in pfSense?

    Steve



  • Hello,

    I'm using 2.1 snap nanobsd on an alix board

    FreeBSD 8.3-RELEASE-p4 #0: Tue Sep 25 12:53:41 EDT 2012
       root@snapshots-8_3-i386.builders.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_wrap.8.i386 i386

    Here's the info about the wifi hardware

    ath0: <atheros 2413="">mem 0xe00c0000-0xe00cffff irq 9 at device 12.0 on pci0
    ath0: [ITHREAD]
    ath0: AR2413 mac 7.8 RF2413 phy 4.5

    and here's the LAN interfaces config

    vr1: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
           options=82808 <vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:16:65:a5
           inet6 fe80::20d:b9ff:fe16:65a5%vr1 prefixlen 64 scopeid 0x2
           nd6 options=1 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
           status: active
    ath0_wlan0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
           ether 00:80:48:6e:56:4d
           inet6 fe80::280:48ff:fe6e:564d%ath0_wlan0 prefixlen 64 scopeid 0xc
           nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
           ssid pfwifi channel 13 (2472 MHz 11g) bssid 00:80:48:6e:56:4d
           regdomain NONE country EG ecm authmode WPA1+WPA2/802.11i
           privacy MIXED deftxkey 3 TKIP 2:128-bit TKIP 3:128-bit txpower 30
           scanvalid 60 protmode OFF burst -apbridge dtimperiod 1 -dfs
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           ether 02:dc:47:8c:e3:00
           inet 192.168.75.253 netmask 0xffffff00 broadcast 192.168.75.255
           id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
           maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
           root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
           member: vr1 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 2 priority 128 path cost 55
           member: ath0_wlan0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 12 priority 128 path cost 370370

    I must maybe disambiguate : I don't have to retype the wifi pass-phrase, between reboots, i have just to reselect the windows 7 network location

    Actually, i've found a page in chinese that i guess seems to propose a solution for the problem by forcing the mac address on the bridged lan interface : http://www.stephenyeong.idv.hk/wp/2010/04/win7_nla_pfsense_bridge/

    – Edit
    Actually it seems this fixed the issue... Cool

    Regards,
    Stéphane</learning,discover,autoedge,autoptp></learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast></hostap></performnud,accept_rtadv></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud></vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,promisc,simplex,multicast></atheros>


  • Netgate Administrator

    So you just spoofed the MAC on the bridge interface?
    That's a really handy tip.  :)
    There must be plenty of people having that problem.

    Steve



  • Yep that's it, and i've now tested on several pfsense alix installs and everywhere the problem is fixed !


  • Netgate Administrator

    This needs to be added as a sticky or FAQ. I haven't read this anywhere else and it must be plaguing plenty of users. I don't actually have any Win7 machines myself.

    Steve


Log in to reply