Problemas com Sarg com SquidGuard



  • Boa tarde.
    Galera fiz a configuração do squid e squidGuard normalmente tudo funcionando.
    Porem fui utilizar o sarg para geração de relatórios.
    Fiz a configuração do sarg porem quando clico na aba View Report ele só mostra conforme imagem em anexo.
    Estou utilizando squid autenticado em base openldap.
    Agradeço




  • que opção de log você marcou na configuração do sarg?



  • Segue em anexo print da configuração.




  • Muda o proxy server para squid e veja se os relatórios são gerados.

    Consegue ver os logs do squid na aba realtime ou na console?

    tail -f /var/squid/logs/access.log



  • No Console consigo ver o log do squid.
    tail -f /var/squid/logs/access.log.

    Mesmo utilizando a configuração do Sarg para utilizar squidGuard eu consigo ver o relatório em realtime.

    Fiz a alteração para o sarg utilizar o squid porem fui ver o relatório ele gerou mas não separou por usuarios.



  • bom dia.
    Fiz o teste novamente utilizando o squid na configuração do Sarg ao inves de squidGuard.
    Gerei o relatório e aparentemente funcionou.
    Mais tarde irei gerar novamente para verificar se esta gerando corretamente.
    Será que o sarg ainda não este preparado para utilizar o squidGuard em seu configurador.
    Agradeço



  • não sei. como não uso o squidguard, apenas inclui as opções do arquivo de configuração no pacote.



  • Bom dia.
    Realmente selecionando squid o relatorio do sarg é gerado.
    O unico problema que ele não mostra o acesso negado dos usuários.
    Pelo que notei o acesso negado é gerado pelo squidGuard e não pelo squid por isso ele não aparece no relatório.


Log in to reply