/etc/inc/shaper.inc error during bootup at line 3007 foreach



  • Just upgraded to 2.1-BETA0 to 17-Oct-2012 snapshot and notice some error ("/etc/inc/shaper.inc foreach error at line 3007") scroll by quickly 4 times during bootup.



  • thats related to the limiter, already a thread open for it at http://forum.pfsense.org/index.php/topic,54595.0.html

    but for me works fine, seems there is another bug in that code, when there r no schedules, the limiter doesnt work so i guess ur facing same, try creating a schedule and assigning it to a limiter if ur using and that should sort it out for now



  • fixed, get a new snapshot.



  • ermal, it needs some more patching as i noticed, the limiter rules with schedule set as none dont work, they give below config compared to the ones that have a schedule assigned which work fine

    
    pipe 5 config 
    
    pipe 6 config 
    
    


  • You went and saved again your limiters and see if that fixes that?



  • i have tried saving them almost 10 times now but still same, i guess its related to the other bug in that limiter adding page, i can see the settigns being saved in the config file but mayb the shaper.inc isnt reading it right



  • i also noticed that when u have multiple bandwidth entries with different schedules then suppose if 2 schedules overlap, meaning both fall active in same period of time then the config file gets written this way, no idea if its even correct

    pipe 5 config  bw 120Kb bw 60Kb
    


  • @xbipin:

    i also noticed that when u have multiple bandwidth entries with different schedules then suppose if 2 schedules overlap, meaning both fall active in same period of time then the config file gets written this way, no idea if its even correct

    pipe 5 config  bw 120Kb bw 60Kb
    

    also to add, if a schedule is assigned to a limiter and if schedule is expired, meaning out of the schedule specified range then also the limiter config falls flat as below

    pipe 5 config 
    
    pipe 6 config 
    

    mayb u need to add more coding to check if the schedules clash or overlap as that might cause limiter errors or u can add a default bandwidth entry with schedule as none, meaning when non of the schedules r active then apply default bandwidth settings so clients dont loose internet access in total as what happens currently or another option can be when no schedules r active then remove the limiter entry in all so it doesnt cause a broken entry



  • deleting a limiter also results in this error with the latest snap

    Fatal error: Call to undefined method dnpipe_class::GetName() in /usr/local/www/firewall_shaper_vinterface.php on line 101 
    

Log in to reply