Lose WAN connectivity after reboot - SOLVED



  • I have been running pfsense 1.01 for a few months.  Whenever the system reboots (usually a local power failure) the pfsense box comes up but I lose connectivity with the ISP.  In the pfsense configuration the ISP gateway IP address is correctly assigned to 24.158.60.1 and the router external (WAN) IP is correct 24.158.60.115.  Internal LAN connectivity is fine except I lose the ISP DNS resolution (as expected).

    netstat -r

    does not show a default gateway

    I can get things to work by manually running ifconfig and route:

    ifconfig re0 24.158.60.115 netmask 255.255.255.0

    and then

    route add default 24.158.60.1

    I have a static WAN IP address and am setting routes without dhcp.

    Any thoughts on resolving this would be appreciated.

    Sam Bowen



  • Can you replicate the same with 1.2b1? There have been so many bugs fixed that 1.0.1 that it's impossible to say if it's something that's been fixed since then. My guess would be that it is.



  • I have upgraded to pfSense version 1.2-BETA-1.  Still no joy.  On subsequent reboots every thing is fine except the static WAN IP is not reachable.

    Initially the netstat -r reports no gateway.

    Ifconfig shows:

    inet 24.158.60.115 netmask 0xffffffff broadcast 24.158.60.115

    I think that the broadcast address of 24.158.60.115 looks bogus but this is what happens after every reboot.

    I checked the /conf/config.xml and the default LAN IP,  the WAN IP and are all correct.

    Once again if I:

    ifconfig re0 24.158.60.115 netmask 255.255.255.0

    route add default 24.158.60.1

    Then netstat -r will show 24.158.60.1 as a gateway.

    Ifconfig then shows:

    inet 24.158.60.115 netmask 255.255.255.0 broadcast 24.158.60.255

    The first netmask looks to me like inet6 format but I am not as familiar with inet6.  At least for inet4  the second netmask and broadcast channels look reassuringly correct.

    I think pfSense is binding (or attempting to bind) a single IP for the server but the ISP gateway doesn't like this.  Perhaps the ISP gateway is not inet6 fluent?

    Sam Bowen, MD



  • After contacting my ISP they revealed that the subnet had been changed on my block of IP addresses to a 25 bit subnet so the problem has been solved by using 24.158.60/25.

    Thanks guys.


Log in to reply