Interfaces leaving and re-entering promiscuous mode?



  • Here's the log that has me wonderin'….

    Jun 19 17:06:52 sshd[96862]: Accepted keyboard-interactive/pam for root from 71.14.18.9 port 4042 ssh2
    Jun 19 17:08:19 kernel: tap1: promiscuous mode disabled
    Jun 19 17:08:19 kernel: rl1: promiscuous mode disabled
    Jun 19 17:08:21 kernel: bridge1: Ethernet address: 7a:93:1e:94:67:01
    Jun 19 17:08:21 kernel: rl1: promiscuous mode enabled
    Jun 19 17:08:32 kernel: tap1: promiscuous mode enabled

    Once logged in, I didn't do anything as I can was on the phone.  I simply put my password in and then left the menu idle.  Shortly after, I lost my putty connection.  Once I logged into the web GUI, that's what I found in the system log.  Also, PingMonitor is going nuts about the interface going up and down.

    Is there something wrong with the NIC or is this an issue with pfSense?



  • What packages are you running? That should be the only thing that'll put interfaces in promisc.



  • I run Bandwidthd, ntop, arping, darkstat, diag_new_states from the pfSense package menu.  The only thing I usually do from ports is like bash.


Log in to reply