Asterisk-gui port submitted to freebsd ports



  • Hi all,

    I've submitted asterisk-gui 2.1-rc1 port to freebsd. If it's approved by freebsd ports team, soon we will have asterisk-gui ready for asterisk pfsense package

    To follow submit status, check http://www.freebsd.org/cgi/query-pr.cgi?pr=172967

    If you want to test a manual build of this package on 2.0.x, after asterisk 1.8 package install, go on console and install it from my personal repo:

    amd64
    pkg_add -r  http://e-sac.siteseguro.ws/packages/amd64/8/All/asterisk-gui-2.1.0.tbz

    i386
    pkg_add -r  http://e-sac.siteseguro.ws/packages/8/All/asterisk-gui-2.1.0.tbz

    To enable asterisk gui:

    1. In http.conf:

    [general]
            enabled = yes
            enablestatic = yes

    1. In manager.conf

    [general]
            enabled = yes
            webenabled = yes

    1. Create an appropriate entry in manager.conf for the administrative user

    [admin]
        secret = thiswouldbeaninsecurepassword
        read = system,call,log,verbose,command,agent,config,read,write,originate
        write = system,call,log,verbose,command,agent,config,read,write,originate

    Troubleshooting

    1. Check your config permissions:
              $ chown asterisk:asterisk /usr/local/etc/asterisk/.conf
              $ chmod 644 /usr/local/etc/asterisk/
      .conf

    Extra steps on first time I've tried to run asterisk gui on pfsense before this package build via ports:
    (not sure if it's still required/needed)

    mkdir /var/lib
    mkdir /etc/dahdi/

    ln -s /usr/local/etc/asterisk /etc/asterisk
    ln -s /usr/local/share/asterisk /var/lib/asterisk

    /var/lib/asterisk/gui_backups
    /var/lib/asterisk/sounds/imageupdate

    chown -R asterisk /var/lib/asterisk
    chown -R asterisk /usr/local/etc/asterisk
    chown -R asterisk /etc/dahdi

    /var/lib/asterisk/static_html/config
    /var/lib/asterisk/scripts

    Donations and feed backs are always wellcome! :)

    att,
    Marcello Coutinho



  • Is it running on NanoBSD installs?



  • I did not tested it yet, the ports submit is still pending…  :(



  • I followed these steps but how do I get the Asterisk GUI to display? Is it the firewalls IP with a specific port?



  • @dovad:

    I followed these steps but how do I get the Asterisk GUI to display? Is it the firewalls IP with a specific port?

    yes, it runs on built in asterisk web server you configured on asterisk http.conf



  • Are any significant changes needed to get this going on pfSense 2.1?  I haven't had any luck with it so far…



  • @mrhanman:

    Are any significant changes needed to get this going on pfSense 2.1?  I haven't had any luck with it so far…

    The first and most important step is to include folder checks.

    But asterisk-gui is a still pending commit port.



  • Will this work on pfSense 2.1-RC0? Or does the move to the pbi-packages mean this will be broken?

    Thanks!



  • Hello!

    installed  Pfsense 2.1-RELEASE  (i386)
    installed Astrisk Version:1.8.19.0 (working Services)
    installed asterisk-gui-2.1.0.tbz

    To enable asterisk gui:

    1. In http.conf:

    [general]
            enabled = yes
            enablestatic = yes

    1. In manager.conf

    [general]
            enabled = yes
            webenabled = yes

    1. Create an appropriate entry in manager.conf for the administrative user

    [admin]
        secret = thiswouldbeaninsecurepassword
        read = system,call,log,verbose,command,agent,config,read,write,originate
        write = system,call,log,verbose,command,agent,config,read,write,originate

    Firewall: open port: 8088

    http://serveraddress:8088/static/config/index.html 
    Web GUI not working…does not open ((  What to do?



  • You maybe need to symlink /usr/pbi/asterisk-arch to /usr/local

    check log files

    I'm still waiting this commit on freebsd ports.  Loooong time waiting.



  • Not to /usr/local but for subfolders that asterisk-gui uses. Try to check log files to see what is missing.



  • /usr/pbi/asterisk-i386/share/asterisk(5): ls -l
    total 6
    lrwxr-xr-x  1 root  wheel  33 Oct 11 01:42 agi-bin -> /usr/local/share/asterisk/agi-bin
    lrwxr-xr-x  1 root  wheel  39 Oct 11 01:44 documentation -> /usr/local/share/asterisk/documentation
    drwxr-xr-x  2 root  wheel  512 Dec 20  2012 images
    drwxr-xr-x  2 root  wheel  512 Dec 20  2012 keys
    lrwxr-xr-x  1 root  wheel  29 Oct 11 01:47 moh -> /usr/local/share/asterisk/moh
    drwxr-xr-x  2 root  wheel  512 Oct 11 01:51 phoneprov
    lrwxr-xr-x  1 root  wheel  32 Oct 11 01:53 sounds -> /usr/local/share/asterisk/sounds
    lrwxr-xr-x  1 root  wheel  37 Oct 11 01:35 static-http -> /usr/local/share/asterisk/static-http

    WebGui http://x.x.x.x:8088/static/config/index.html Opened ))) , but

    The GUI does not have necessary privileges.
    Please check the manager permissions for the user ! (((

    manager.conf
    read = all
    write = all

    ?????



  • Hi anazak
    did you got gui working for you
    I have the config


    Not Found

    The requested URL was not found on this server.
    Asterisk Server




  • @akha666:

    Hi anazak
    did you got gui working for you
    I have the config


    Not Found

    The requested URL was not found on this server.
    Asterisk Server


    Working URL.  no access to the config. I do not know what to do




  • does anyone have a working Asterisk GUI?

    When i go to http://MyIp:8888/gui/static/
    I get:

    Access Denied

    You do not have permission to access the requested URL.

    Asterisk Server


    http.conf

    [general]
    enabled=yes
    enablestatic=yes
    bindaddr=0.0.0.0
    bindport = 8888
    prefix = gui
    enablestatic = yes

    –----------------------------------------
    manager.conf

    [general]
    enabled = yes
    webenabled = yes
    port = 5038
    bindaddr = 0.0.0.0

    [admin]
    secret = admin
    read = system,call,log,verbose,command,agent,user,config,read,write,originate
    write = system,call,log,verbose,command,agent,user,config,read,write,originate
    ipermit=0.0.0.0

    some one that know how to fix??


Log in to reply