WAN/DHCP on pfsense 1.2 Beta 1



  • I'm a pfsense & freebsd newbie, but i have download the pfsense 1.2 Beta 1 iso and burned it to a cd. I've managed to install it on a box I have with a Realtek RTL8139C NIC and also a dual port intel 10/100/1000 NIC.  Pfsense detects the cards appropriately (as best as I can tell) and I've setup the cards as follows:

    WAN1 = EM1
    LAN1 =  EM0
    OPT1 = RL1

    I can access pf sense internally from my network (http://192.168.0.1) however the I can't seem to get the WAN port to obtain an IP address. From status -> interfaces I can release and renew DHCP all I want but no IP shows up:

    Status up 
    DHCP up [RELEASE]   
    MAC address 00:0d:56:35:16:d8 
    IP address 0.0.0.0   
    Subnet mask 255.0.0.0 
    ISP DNS servers 
    Media 1000baseTX <full-duplex> 
    In/out packets 0/0 (0 bytes/7 KB) 
    In/out errors 0/12 
    Collisions 0 
    Interrupts/Second fxp0 total
    2 rate

    I am using Time Warner Road Runner (Cable) and I haven't had any problems connecting up routers before. In fact I have a smoothwall and a netgear router working fine. If I do an ifconfig I get the following:

    $ ifconfig
    rl0: flags=8802 <broadcast,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>ether 00:c0:26:2f:ee:09
    media: Ethernet autoselect (10baseT/UTP)
    status: no carrier
    em0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=b <rxcsum,txcsum,vlan_mtu>inet 192.168.0.253 netmask 0xffffff00 broadcast 192.168.0.255
    inet6 fe80::204:23ff:febf:4ca6%em0 prefixlen 64 scopeid 0x2
    ether 00:04:23:bf:4c:a6
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    em1: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=b <rxcsum,txcsum,vlan_mtu>inet6 fe80::20d:56ff:fe35:16d8%em1 prefixlen 64 scopeid 0x3
    inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
    ether 00:0d:56:35:16:d8
    media: Ethernet autoselect (1000baseTX <full-duplex>)
    status: active
    lo0: flags=8049 <up,loopback,running,multicast>mtu 16384
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
    pflog0: flags=100 <promisc>mtu 33208
    pfsync0: flags=41 <up,running>mtu 2020
    pfsync: syncdev: lo0 syncpeer: 224.0.0.240 maxupd: 128
    enc0: flags=41 <up,running>mtu 1536

    I've also tried:

    • Downgrading to pfsense 1.0 (that didn't work).
    • Changing NICs (no luck there either)
    • Testing the network cable by plugging it into a laptop (that works fine)
    • Running "dhclient em1" from SSH (no luck there)
    • Assigned a host name (under system:general)
    • Unchecked "Block Private Networks" (under Interfaces: WAN)
    • Assigning a Hostname (under Interfaces: WAN -> DHCP Client Configuration)
    • I've checked the system logs and didn't see anything particularly revealing (I can post those if they would be helpful though)

    I'm stumped :) What am I doing wrong?

    Thanks
    Brad</up,running></up,running></promisc></up,loopback,running,multicast></full-duplex></rxcsum,txcsum,vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></rxcsum,txcsum,vlan_mtu></up,broadcast,running,simplex,multicast></vlan_mtu></broadcast,simplex,multicast></full-duplex>



  • Some sort of ISP issue. Power cycling your modem might fix it. Not sure how Road Runner works, you might have to call them or go through some other process to register a new device, or you may have to spoof the MAC of a previously used device on the WAN.



  • I considered it might be a RoadRunner issue however:

    1. I can alternate between a netgear and smoothwall router without doing anything special
    2. I placed the pfsense box behind the smoothwall:
      Cable Modem -> Smoothwall (w/DHCP Server) -> Switch -> PFSense Box -> Laptop (connected via xover cable)

    PFSense can't obtain an IP from the smoothwall either… (I did unchecked "Block Private Networks" (under Interfaces: WAN))

    Thanks
    Brad



  • And Google shall set ye free!

    All I had to do was run this command:
    echo 'hint.acpi.0.disabled=1' > /boot/loader.conf

    Kudos to geek00L at:
    http://geek00l.blogspot.com/2007/03/network-interface-watchdog-timeout.html

    Thanks
    Brad



  • Ah, yeah you didn't say you were getting watchdog timeouts. Glad you found the issue!



  • I know you already fixed your issue, but I had the exact same issue when I first disconnected my WAN connection from my Netgear router to the WAN port of my box running pfsense, and I also have Time Warner as an ISP.  WAN would not obtain an IP address until I power-cycled the cable modem.  I wonder if the cable modem doesn't like changing the MAC address it connects to if it's already been connected to a different device previously.



  • @fcapizzo:

    I know you already fixed your issue, but I had the exact same issue when I first disconnected my WAN connection from my Netgear router to the WAN port of my box running pfsense, and I also have Time Warner as an ISP.  WAN would not obtain an IP address until I power-cycled the cable modem.  I wonder if the cable modem doesn't like changing the MAC address it connects to if it's already been connected to a different device previously.

    That has been my experience as well when changing Mac addresses on Insight cable as well.


Log in to reply