Comcast Native IPv6



  • I am having issues getting an IPv6 address on my LAN connection. I have a /64 address on my WAN connection (Which I thought was suppose to be a /128), I am getting connectivity out of the WAN.

    I setup the WAN connection to be:

    IPv6 Configuration Type: DHCP6
    DHCPv6 Prefix Delegation size: 64

    and the LAN to be:
    IPv6 Configuration Type: Track Interface
    IPv6 Interface: WAN
    IPv6 Prefix ID: 0

    Any thoughts on what I setup wrong?


  • Rebel Alliance Global Moderator

    I have been unable to get comcast native to work at all.  I need to spend some time and try again.  But to be honest just not worth the hassle currently.  My Hurricane tunnel works perfect, it would be nice to go native.

    But to be honest I don't think comcast has their stuff as stable as it should be as of yet ;)



  • Has anyone tried using IPv6 on business class internet from Comcast?



  • You can get native IPv6 with business class if you do not have static IPs. I'm not sure about which modems will work with it but I do know the SB6120 will work. One last thing I can think of is that you must be in an area where the CMTS is from Arris in order to get IPv6.



  • I do not have any static IPs and I am running a SB6121. Where can I see if I am in the area for CMTS is from Arris?



  • wcktklwn, your settings look to be the same that I'm using. Native dual stack works well for me with Comcast. The /128 address you get is for the WAN and the /64 subnet is for the LAN. If the LAN interface of pfsense isn't getting an address then something may have gone wrong.

    What snapshot are you using? You may need to upgrade to the latest.

    If you have ipv6 connectivity on the WAN that isn't through a tunnel then you're probably in an Arris area. You can look up the CMTS mac address in the modem log page. Mine fills up with random warnings and errors that mention the CMTS mac address. Take the first half of the mac address and do a OUI lookup (just google it if you're unfamiliar)



  • darkcrucible,

    The problem I am getting is that I am receiving a /64 address on my WAN not a /128 and that is what confuses me. I started with using the snapshots at http://snapshots.pfsense.org and when that failed I tried doing a playback gitsync master and that didn't help. Both of which were in the last couple of days.



  • Here are some screenshots to see if this helps anyone.

    I checked into my CMTS mac and it turns out to be a Cadant Inc mac address. After some research Cadant Inc was acquired by Arris







  • Rebel Alliance Global Moderator

    Mine is the same "Cadant" Im on a sb6120

    Like I said, they are not as stable as they think they are..  I wouldn't mind the low ping times your showing there vs my tunnel times.  So maybe this weekend I will give it a go again.

    But I don't think your issue is pfsense related to be honest.  When you plug a box directly into your modem – do you get your /128? vs your routed /64



  • Check this out: http://www.dslreports.com/forum/r27186774-IPv6-Evidence-of-Comcast-IPv6-CPE-Dual-Stack-CPE-and-CPEPD-

    The 2001: address that you see is your /128. When I say /128 I mean that you were given a subnet of usable address(es) in a /128. With DHCP6-PD, you are additionally given a /64 subnet. This /64 subnet should start with a 2601: In my situation, pfsense assigns itself something from the /64 subnet on the LAN and starts offering that subnet on the LAN. Something has gone wrong with this part for you.

    I notice on your gateway page you have multi-wan? I don't have any experience with that so my only suggestion is to disable it temporarily and see if the the prefix delegation starts working for your LAN.



  • I tried disabling that interface and it doesn't seem to make any difference.



  • I have the same issue , meaning i only get the /64 asigned to the wan , and can't see the /128 , lan has no ipv6 .
    Same config - dhcpv6 /track interface -prefix id 0



  • I managed to get this working. I believe I snort had something to do with this. Once I removed it and did a upgrade to pfsense the problem went away.



  • We just checked in a fix for this, get a snapshot dated january 6th or later please.
    We changed the DHCP6 client back to the WIDE client which should work better.


Locked