Bridge and multicast



  • I have a multi-nic, multi-vlan box I'm running 2.0.1 on and bridging multiple sites over fiber with. Transparent, no nat.
    I can't seem to get multicast sent over if1 and if2 from if0.
    if0_vlan820 no ip
    if1_vlan820 no ip
    if2_vlan820 no ip
    bridge0 ip'd at 192.168.76.4 and is a bridge containing the above.

    on if0_vlan820 and bridge0, I can see from tcpdump:
    15:48:42.538025 IP 192.168.76.11.7771 > 239.192.168.76.1770: UDP, length 1392
    15:48:42.538034 IP 192.168.76.11.7771 > 239.192.168.76.1770: UDP, length 1392
    15:48:42.538137 IP 192.168.76.11.7771 > 239.192.168.76.1770: UDP, length 1392

    I've tried adding rules for everything. Explicitly for 239.x, explicitly for UDP, explicitly from that IP you name it.  Occasionally, if I add in a float rule to quick block 192.168.76.11, it'll show up in the firewall log. But not as often as it's sending.
    DHCP passes on all interfaces/bridges(2 other vlans as above).

    Any ideas of something I may have missed when initial setup?   Or anything I can check to dig deeper?

    Thanks!

    I should probably mention that I have tried to see if igmpproxy would apply, but as the bridge members do not have ips assigned, igmpproxy doesn't run.


Log in to reply