Update TZ database?



  • There seem to be a problem with the TZ definitions on pfSense 2.0.1. Setting the timezone to Argentina, the time in dashboard is OK, but the time in both the logs and the console is 1 hour behind (this was also mentioned here, this is not a matter of restarting the box, and it is not set as a GMT offset)

    I have read that this can be fixed by upgrading the TZ database, getting the updated files from another FreeBSD installation. Is this right?

    I don't really have any other FreeBSD system available, could anyone post the files and where exactly to put them on the pfSense disk?
    Or maybe they can be got from somewhere else, like a repo or FreeBSD ISO?

    Thanks!


  • Rebel Alliance

    I have not tested, but if you want to try (at your own risk)….

    Attached, from a 2.0.2 test box that don't have the Timezone issue:

    
    zoneinfo.tgz ---> /usr/share (zoneinfo.tgz.xls, remove the .xls)
    
    

    Please backup the original file before do anything ;)

    Edit: seems that you only need to copy the zoneinfo.tgz to /usr/share  & reboot your pfSense….. thats all

    Edit 2: Tested on my production pfSense 2.0.1-RELEASE (amd64)  and woks OK  ;D

    zoneinfo.tgz.xls



  • Great, it works! Gracias jaja XD

    For the record, on a nanoBSD installation you first have to mount the filesystem as read-write by:

    /etc/rc.conf_mount_rw
    

    Then replace the files via SSH or whatever.

    Cheers!



  • and when you are finished changing things on the CF card:

    /etc/rc.conf_mount_ro
    

    Set it back to read-only.



  • @phil.davis:

    and when you are finished changing things on the CF card:

    /etc/rc.conf_mount_ro
    

    Set it back to read-only.

    Or restart the box (anyway you have to restart the box)

    Furthermore, I noticed I had to change the timezone to something else, back to the proper setting and then restart again for everthing to be properly configured. Otherwise some log entries like the DHCP ones were still showing the incorrect time.

    Regards!



  • Some of the more obscure timezones have updated names - e.g. the old spelling of "Katmandu" is now corrected to "Kathmandu" - so if you have something like that selected, then you certainly have to use the pfSense GUI and select the new correct timezone name.


Log in to reply