PfSense Routing for Isolated Lab



  • I am new to this forum and to pfSense. I am trying to set up an "ISOLATED" virtual lab in Virtualbox for certification purposes. I installed 1 Windows Server 2008 R2 Enterprise vm, 2 Windows 7 Enterprise 64-Bit vms, and a pfSense vm (for routing). I have set the pfSense with 2 NICs in Virtualbox, one bridged em0 and one internal em1. em0 IS receiving a DHCP address and em1 has been set statically with 192.168.1.1 /24. On the server I have set it with the IP of 192.168.1.2 /24 with a gateway of 192.168.1.1. I can't ping the pfSense vm from the the server. Is there something that I am missing? Can anybody help me?



  • From the command prompt on the windows server see if you are getting arp responses:  "arp -a"
    You should see an arp entry for your 192.168.1.1, with the MAC address of the pfsense em1.
    This means your em1 virtual network is working.  Try checking the firewall to see if firewalling is turned off:
    Menu: System ->Advanced and check "Disable All Filtering".
    Also check the interfaces setting to see if "Block RFC1918" is set to On.  (Checked).  Since you have RFC1918 on the wan/outside
    you want this disabled.

    The firewall's ARP table is viewable from Diagnostics->Arp Table, if you are still seeing issues.
    You probably already know that 2008 defaults to having ICMP Ping turned off by default, but if not, try checking that.  (Although you
    still should be able to ping from the server to the pfsense box.)

    Jeremy



  • Thank you. I can now ping all devices in the virtual network.


Log in to reply