Varnish3 Package + GUI seems broken



  • The Varnish3 Package + GUI seems broken. ACL is Corrupt.
    Version: Latest PFSense 2.1 DEVELOPMENT snapshot

    When clicking to LB Directors following Error is showing up:
    Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69

    CRASH Report:
    Crash report begins. Anonymous machine information:

    amd64
    8.3-RELEASE-p4
    FreeBSD 8.3-RELEASE-p4 #1: Tue Sep 4 17:09:36 EDT 2012 root@snapshots-8_3-amd64.builders.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8

    Crash report details:

    PHP Errors:
    [06-Sep-2012 09:32:57 UTC] PHP Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69
    [06-Sep-2012 09:33:21 UTC] PHP Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69
    [06-Sep-2012 09:34:57 UTC] PHP Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69
    [06-Sep-2012 09:35:17 UTC] PHP Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69
    [06-Sep-2012 09:35:24 UTC] PHP Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69
    [06-Sep-2012 09:35:29 UTC] PHP Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69

    Filename: /var/crash/minfree
    2048

    Seems like the ACL

    Whe i run varnishd in Debug Mode i get this Output:
    Message from VCC-compiler:
    Expected an action, 'if', '{' or '}'
    ('input' Line 79 Pos 17)
    else {
    –--------------####-----

    Running VCC-compiler failed, exit 1

    VCL compilation failed



  • I'll test it when I have time(really busy these days).

    Do you have any 2.0.1 with varnish3 and the same config just to check if your config is ok?



  • The 2.0.1 worked perfectly with the varnish3 build. I've tried another custom .vcl by manually loading it. that worked flawless.
    so it seems there is a lil logical problem in the varnish config build process.. looks like it cuts off some important lines which the web gui should write to config file.



  • maybe something related to php 5.3 as 2.0.1 and 2.1 varnish package use the same gui code.



  • it wouldn't wonder me if pfsense 2.1 uses php5.4. but on 5.3 i dunno if this makes much difference.



  • IIRC, pfsense 2.0.1 uses php 5.2 and 2.1 uses 5.3

    On 5.3 some functions used on current packages are deprecated.



  • ahh well i see. yes that could be the problem ;-)


Log in to reply