Dansguardian packaged installs but not visible on webConfiguration menu



  • pfS: 2.0.1 AMD64
    Dansguardian: beta 2.12.0.0 pkg v.0.1.6_1 platform: 2.0
    Squid3: 3.1.20 pkg 2.0.5_5

    I install Dans from the package manager.  No errors reported during the install process.  I can see a rolling alert that Dans is updating the blacklist.  I click on the services menu and expect to see Dansguardian but it isn't there.

    It shows under Installed Packages.  I uninstall/reinstall no luck.  What am I doing wrong?

    Also, what config files do I remove/change to fully uninstall?  When I have reinstalled in the past, it used to show and the configuration I setup is already plugged in.  So there must be some residual config it's reading…

    Thanks



  • try a package reinstall, I saw this issue few times with some packages.

    remember to install/reinstall squid3 after dansguardian.



  • ~~I've read posts where I need to install squid3 before I install Dansguardian.  Is that still true?  I have been doing that, but still, no luck.

    I have uninstalled both Dans and squid3.  Rebooted.  Installed squid3, installed Dans but no luck.

    suggestions?

    thanks for your help~~
    Whoops!  I just re-read your post.  I have been doing the install in the wrong way.  First is Dans, second is squid3.  Ok.  Lets try that…



  • ???  Bummer!  Still no luck.

    I uninstalled both, rebooted (not necessary?), installed Dansguardian, no errors, the scrolling alert notification told me Dansguardian was updating.  I mouse hovered over "Services", I saw "Dansguardian", mouse clicked on the "Acknowledge
    All" alert notification and then went back to "Services" and Dansguardian was gone.  Dansguardian shows up under Installed Packages but not in the Services' menu and not in Status/Services.

    Installed Squid3, no errors, and Dansguardian never came back.

    Any ideas?  Thanks.



  • wait package install (without reboot), if you press the Acknowledge, you will force a reload on package install page.

    I'm sure that dansguardian package install is working.  :)



  • removed both.
    installed dans
    ignored the scrolling alert, went to dansguardian under the services menu.  Clicked a few tabs, no problems.
    went to services on the menu and dansguardian was no longer there.  dansguardian went missing from the services menu again.
    I can navigate to dans via typing in the URL (https://<ip>/pkg_edit.php?xml=dansguardian.xml) but it just doesn't stay registered or visible on the services menu and never shows in status/services.

    ???

    This new install of pfS just doesn't like me.</ip>



  • …. after the Dansguardian menu and service listing disappears, if I reinstall the GUI component, it looks like it makes those two listings appear again.  So far so good.


Log in to reply