Snort Fatal Error



  • pfSense 2.0.1-RELEASE
    Snort 2.9.2.3 pkg v. 2.5.1

    Snort crashed with the following fatal error:

    snort[47192]: FATAL ERROR: What is this "l"(0x6C) doing in your binary buffer? Valid hex values only please! (0x0 - 0xF) Position: 2

    It is not the 1st time it crashes, so I will check again the next time it happens to provide more feedback.
    Any ideas?

    I will upgrade to 2.5.2 and let's see if it will happen again.



  • I updated to latest versions two days ago but today snort crashed again with the following error.

    Services: Snort 2.9.2.3 pkg v. 2.5.2

    snort[11369]: FATAL ERROR: Character value out of range, try a binary buffer.



  • Have you tried a complete uninstall (without keeping settings?) and a complete new install?



  • A complete uninstall and reinstall "without keeping settings" solved the problem.


Locked