How to restore squidguard default config ?



  • Hi,

    How can i restore squidguard default config ?
    On my pfsense, in common acl -> target rules, i always see !blk_blacklists_adult !blk_blacklist_porn all
    I can't remove them.
    These entries are left by and old blacklist, not used anymore.

    I tried :

    • redownloaded old blacklist, change these categories to whitelist, allow, –-, save, restart --> do not work.
      categories are here, but always denied.

    • blacklist -> restore default -> do not work

    • untick enable blacklist in general tab : do not work

    • uninstalled package, remove /usr/local/etc/squidguard, /usr/local/www/s..., /var/squidg..., /var/db/squig..., then reinstalled it : do not work

    • manually edited /usr/local/etc/squigard files (conf, xml) to remove lines about this : do not work.

    What else can i try ? Where is config stored ?
    permission problem ?



  • i did a backup/restore, and erased lines about "!blk_blacklists_adult !blk_blacklist_porn all"
    in xml config file.

    It worked, but problem still remain intact : target rules are read-only, i can't save any modification.

    ???


Log in to reply