Struggling with bridge setup



  • Prior to today, my ISP provided me with a block of addresses and I was using just one.

    The line in connected to a netgear router and the netgear was setup to use the address x.x.x.218, with mask 255.255.255.248 (/29 right?), and gateway x.x.x.217

    Today, I tried to setup a couple old computers and a switch in such a way as to use more than just .218.  With one computer that has two network interfaces: LAN (re0) and WAN (nfe0).  I installed pfsense and then loosely followed the steps below:

    1. Disable NAT and Firewall

    2. Bridge WAN and LAN

    3. Create OPT interface and assign the network port to the bridge created in #2

    4. Change OPT interface to static and give it IP x.x.x.220/29

    5. Turn off DHCP on LAN and set WAN and LAN interfaces both to type "none"

    6. plug the line from the outside into the WAN jack

    7. connect the LAN jack to an old 5 port switch
      8 ) connect the netgear, having changed no settings on it, to the switch

    And then that all seemed great.  The computers on the other side of the netgear continued to operate as though nothing had changed.  But here's what I can't figure out: When I take another computer and set it to use x.x.x.219/29 and the same gateway (217) and DNS and everything as the netgear, it seems to be unable to connect out to the internet.

    Using a computer connected to the netgear, I can still change settings through the webconfigurator by going to https://x.x.x.220.

    So I am worried that somewhere along the way I have completely misunderstood how bridges are supposed to work and be set up.  Can anybody help point me back in the right direction?  Where did I go astray in trying to make use of the multiple public IPs I've got?



  • Apparently this was something wrong on the ISP side of things.  Having now spent a lot of time talking to them and them extracting more time and money out of me, all is working as intended.  I'm not totally sure what's going on still but for now I am ok with that.


Log in to reply