Pfsense i386 , 2.1 virtio , okay on my i5-2500T , not on i3-3220T



  • Hi Pfsense.

    I have installed the latest snapshot , and inside Pfsense everything is working fine.
     When i try a wget on the host system to google.com it just hangs.

    wget google.com
     –2012-11-17 17:15:20--  http://google.com/
     Resolving google.com... 173.194.70.138, 173.194.70.101, 173.194.70.100, ...
     Connecting to google.com|173.194.70.138|:80... connected.
     HTTP request sent, awaiting response...

    I can telnet google on the HTTP port no problem , if I use the em0 , em1 , everything
     is working fine.

    Tried a lot of things , but nothing help....

    /Best Michael



  • Hi…

    Using another not with the i3-3220T inside , And now it works.

    Funny was is the problem with these 2 tested gen3 Intel's.

    /Michael



  • If youre willing to go deeper inside…

    I have  seen 8-STABLE contains some virtio-drivers that are more recent thant what is currently backported
    from CURRENT inside pfSense 2.1.

    But since I don't have (yet) equipment where I could verify it doesn't break things, I have prepared a
    patch that I might do a pull request for, you can 'git apply' this gist if you have the time

    https://gist.github.com/4118393



  • Hi Matsim…

    Please guide me a little further ,cause i'm a newbie regards git.

    Today I have changed the virtio driver to e1000.

    Then everything works as expected...

    /Best Michael


Locked