Can't Install on Mini-ITX PC from USB CD-ROM



  • Hi,

    I've done some searching, but haven't been able to fix this issue.  I'm trying to install pfSense 2.0.1 (64-Bit) using a Samsung USB CD-ROM, onto a Jetway Mini-ITX PC - which has an Intel Atom D525 Processor and associated chipset with 4 USB ports and 2 LAN ports.  The BIOS sees the USB CD-ROM drive fine, and I can boot of the pfSense CD and get to the menu.  However, when I select #1 - Default Install, it goes through the boot process and then gets to the "mountroot" command prompt.  From there it either will hang, or sometimes it will allow me to type at that command line, and I've tried mounting the CD drive per the example, but it just continues to show the mountroot message.

    Any suggestions on how to resolve this are appreciated.

    Thanks.



  • What is the response when you type "?" at the mountroot> prompt?

    Do you have a disk to install to?

    Have you tried a pfSense 2.1 snapshot build? (2.1 snapshots use FreeBSD 8.3 as the operating system. FreeBSD 8.3 has more up to date devices drivers than those included in pfSense 2.0.1.)



  • I've had this problem it was solved by one or both of the following:

    1. Verify the check sum to ensure that your image is not corrupt.
    2. Plug in the second USB connector if your USB CDROM has a "Y Splitter" for extra power.


  • I was having the same problem and I ended plunging the hard drive to my PC and flashing: pfSense-2.0.1-RELEASE-4g-i386-nanobsd_vga.img to the disk using win32diskimager.


Locked