It doesn't reboot from GUI or console



  • As the subject says, to restart the system I need to press the power button off/on.
    From the GUI or console, it just hangs as below:

    login as: root
    Using keyboard-interactive authentication.
    Password:
    *** Welcome to pfSense 2.1-BETA0-pfSense (amd64) on nextsense ***

    WAN (wan)      -> em1        -> v4/DHCP4: 187.64.xxx.xxx
    /23
    LAN (lan)      -> em0        -> v4: 192.168.250.1/24

    1. Logout (SSH only)                  8,) Shell
    2. Assign Interfaces                  9) pfTop
    3. Set interface(s) IP address      10) Filter Logs
    4. Reset webConfigurator password    11) Restart webConfigurator
    5. Reset to factory defaults        12) pfSense Developer Shell
    6. Reboot system                    13) Upgrade from console
    7. Halt system                      14) Enable Secure Shell (sshd)
    8. Ping host                        15) Restore recent configuration

    Enter an option: 5

    pfSense will reboot. This may take a few minutes, depending on your hardware.

    Do you want to proceed [y|n]? y

    pfSense is rebooting now.
    Stopping package squid…done.
    Stopping package mailreport...done.
    Stopping package Notes...done.
    Stopping package phpSysInfo...done.
    Stopping /usr/local/etc/rc.d/proxy_monitor.sh...done.

    pfSense 2.1-BETA0 (amd64)
    built on Mon Nov 19 09:10:59 EST 2012

    Computer: Supermicro SYS-5015A-PHF (Atom D510) - memory 2Gb



  • i had the same experience too.  ??? ???



  • Normally these are bios/board bugs.
    If you find a fix that can be applied in pfSense without too much complexity i can give a look.

    You can try setting this options:
    hw.acpi.handle_reboot=1
    or
    hw.acpi.disable_on_reboot=1

    Please try them separately and see if they make a difference.



  • @ermal:

    Normally these are bios/board bugs.
    If you find a fix that can be applied in pfSense without too much complexity i can give a look.

    You can try setting this options:
    hw.acpi.handle_reboot=1
    or
    hw.acpi.disable_on_reboot=1

    Please try them separately and see if they make a difference.

    Thanks for the reply, ermal.
    When I was running pfSense 2.0.1 Release it did not happen, reboot was working fine and I didn't change anything on BIOS settings. It's hard to believe in any bug on a Supermicro Board/Bios but, whatever, it can happens.
    Anyway, where to insert those setting options?:
    1- /boot/loader.conf
    2- /boot/loader.conf.local



  • Either of those.
    Usually its recommeneded the .local one.

    Well the bug might be even in the acpi implementation of FreeBSD i did not do any search on that.



  • @ermal:

    Either of those.
    Usually its recommeneded the .local one.

    Well the bug might be even in the acpi implementation of FreeBSD i did not do any search on that.

    Ok. I'm going to try and report it back as soon as possible. Separately, as you said before.
    Thanks again.



  • Well, it works on the first try.

    Procedure:
    1- Copy loader.conf.local and rename to loader.conf.bkp.local. The original loader.conf.local content is as below:

    kern.cam.boot_delay=10000

    2- Edit and save loader.conf.local as below:

    hw.acpi.handle_reboot=1
    kern.cam.boot_delay=10000

    But on second try, it still hangs. :(



  • It not works even with loader.conf.local as below:

    hw.acpi.disable_on_reboot=1
    kern.cam.boot_delay=10000

    :(

    I'm posting this while that reboot message remains on my screen:

    pfSense is rebooting now.
    Stopping package squid…done.
    Stopping package mailreport...done.
    Stopping package Notes...done.
    Stopping package phpSysInfo...done.
    Stopping /usr/local/etc/rc.d/proxy_monitor.sh...done.



  • Halt from GUI or console doesn't work as well. I still need to press the power button off/on.



  • @johnnybe:

    Halt from GUI or console doesn't work as well. I still need to press the power button off/on.

    I note proxy_monitor.sh. Try uninstalling squid and test. Then try installing the squid3 package instead.


Locked