Port Forwarding SMTP läuft ins Leere



  • Hallo zusammen,

    ich möchte gerne den Smtp Port über das Wan an unseren Smtp-Server weiterleiten, hierzu habe ich einen Alias (domino2) für unsern Smtp-Server mit der internen IP-Adresse angelegt und  unter Firewall: NAT: Port Forward folgendes eingestellt:

    IF Proto Src. addr Src. ports Dest. addr Dest. ports NAT IP NAT Ports Description
    WAN TCP * * * 25 (SMTP) domino2 25 (SMTP) SMTP Weiterleitung
    [Firewall rule ID is managed with this rule]
    (leider bekomme ich die Werte mit Tab's nicht genau übereinander ;-( )
    Die Firewallregel habe ich automatisch erstellen lassen und logge diese auch mit:

    Proto Source Port Destination Port Gateway Queue Schedule Description
    TCP * * domino2 25 (SMTP) * none  NAT SMTP Weiterleitung

    Wenn ich jetzt über telnet eine Verbindung von außerhalb herstelle sehe ich in den Systemlogs unter Firewall, dass die Verbindung durchgelassen wird. Es kommt aber leider nichts an. Im Lan funktioniert die Verbindung, die Firewall des Servers lässt den Port durch.
    Wie kann ich feststellen, wo die Anfrage hinläuft, im Log sieht es fast so aus als ob pfsense die Anfrage wieder zurück ins Internet schickt.

    Act Time If Source Destination Proto
    pass Nov 21 11:40:21 WAN "AbsendeIP":51403 "interneIP":25 TCP:S

    Muss ich noch irgendwo eine zusätzliche Verbindung zwischen Wan und Lan aktivieren???

    Ich bin ziemlich ratlos.

    Mit einer M0n0wall funktioniert die Weiterleitung mit dieser Einstellung auf diesen Smtp-Server; allerdings in einem anderen IP-Bereich.

    Hat evtl. einer einen Rat für mich

    Schon mal vielen Dank und Gruß Dominique



  • kannst du vll mal nen tcpdump auf das WAN interface machen ? vll sieht man da mehr …

    lg



  • Hallo lg,

    danke für den Tip, dieses tcpdump ist ja mal ein mächtiges Ding.

    Kennst du dich damit aus und kannst mir sagen wie der Befehl am besten ausehen könnte.
    Arbeite mit der Linux Version auf Centos.

    wenn ich über
    tcpdump hostname "interneIP"
    mitschneide dann zeigt er die internen Verbindungen schön an, sobald ich aber von außerhalb also über das Wan mich verbinden will kommt kein Paket an.
    Was kann ich in der pfsense noch einstellen dass diese durchgehen?

    Gruß und Danke Dominique

    Bin mich auch am einlesen aber das ist sehr undurchsichtig ;-)

    Gruß Dominique


Locked