Paginas demorando pra carregarem



  • Boa tarde Pessoal, sou novo no pfSense, mas tenho conhecimentos razoaveis sobre AD e criei um aqui na empresa que trabalho e para proxy instalei o pfSense com o squid e o squidguard, porem o problema é que nas estações está demorando muito para carregar uma pagina, queria umas opiniões de como resolver isso, seria no gerenciador de cache? Segue as configurações que setei:

    Cache Mngmt

    hard disk cache size: 5000
    memory cache size: 512 ( Memoria da VM total 2048)
    Minimum Object size: 0
    Maximum Object Size: 256
    Maximum Object Size RAM: 32
    Level 1 Subdirectories: 64
    M. Replacement Policy: Heap LFUDA
    C. Replacemente Policy: Heap LFUDA

    O que poderia fazer para resolver isso? Grato a todos que puderem contribuir.



  • se a vm ta 2048 , poderia utilizar até 50% ou seja 1024 no memory size , o hard disk size eu sugeria 4GB  , teria que ver também a parte de traffic mgmt , agora  se ela esta em uma VM precisa ter cuidado pois dependendo da sua placa de rede, o gargalo se encontra ai.

    Na minha opinião proxy em cache não é interessante virtualizar principalmente por questões de I/O do disco.



  • No meu caso não tenho outra opção de maquina, porem no servidor proxy virtualizado estou usando a Wan como externa (fisica que recebe dhcp do roteador) e para lan eu criei uma placa interna no Hiper-v.



  • Correto então a topologia seria assim :

    INTERNET –----> WAN-PFSENSE(placa FISICA) -------> LAN-PFSENSE (Virtual)  -------> Estações de trabalho     ?

    neste caso vejo somente 1 placa de rede física onde esta passando o trafego.

    Este servidor virtualizado possui quantas placas de rede?

    Porque pelo modo que você esta apresentando eu estou vendo dessa maneira.

    Se possível coloque o hardware do equipamento , e se possui mais de 1 máquina virtual instalada , quais são elas, necessário mais detalhes.



  • É exatamente assim que está funcionando.

    Tenho um Servidor Físico Server 2008 R2. com duas placas de rede. (uma recebe do roteador e a outra serve a rede interna)
    Pelo Hyper-v Virtualizei os seguintes servidores:

    • AD, DNS (Wan fisica, Lan Fisica)
    • Proxy (pfsense com DHCP ativo) -> (Wan Fisica, Lan Virtual)

    Obs: Percebi que quando instalei o Firefox 17 o acesso funcionou aparetemente bem, sem demoras para carregar as paginas.



  • Nesse caso seria interessante acrescentar uma 3ª placa de rede fisica para dedicar ao Proxy server? Seria essa uma possivel solução? Abraço



  • Olha é provável que melhore sim , porque veja , você tem um gargalo na placa de rede , se estamos falando de cache e acesso a internet , proxy ,  dependendo do volume de computadores, cria uma fila grande de requisições.

    Então é necessário prever delay de I/O que é acesso ao disco, memória , e  poder de processamento , imagino que sua rede de 10/1000 Mbps, então diante desses fatores é possível que o acesso ao cache esteja com um certo lag.

    Provavelmente deve ter alguma ferramenta de analise do trafego de saída e entrada da placa de rede para o windows , faça esse monitoramento e veja como esta a latência , tempo de reposta.

    Tudo sem contar a virtualização.

    Não quero te assustar ou te desencorajar , mas estou apontando algumas observações referente o que você postou, se eu tiver falando asneiras sinceramente peço desculpas.



  • Que isso brother, até te agradeço as dicas, de fato é exatamente assim que o servidor esta montado, tenho uma 3ª lan que esta desativada, vou ativa-la para dedicar somente ao proxy, pode ser até que resolva, em todo o caso mais uma vez meu agradecimento. Vou tentar aqui e volto a postar se for dada solução.



  • @nofault:

    Provavelmente deve ter alguma ferramenta de analise do trafego de saída e entrada da placa de rede para o windows , faça esse monitoramento e veja como esta a latência , tempo de reposta.

    Sobre a ferramenta de análise do tráfego para windows, costumo usar o iperf (linha de comando) ou ainda o jperf (com interface gráfica).



  • Instalou o pfsense com o softupdates na partição do cache????



  • @marcelloc:

    Instalou o pfsense com o softupdates na partição do cache????

    Na verdade como sou iniciante não sei como, tem algum topico no forum explicando como? Abraço.



  • @martinelle:

    @marcelloc:

    Instalou o pfsense com o softupdates na partição do cache????

    Na verdade como sou iniciante não sei como, tem algum topico no forum explicando como?

    Tem aqui, pelo próprio marcelloc:
    http://nextsense.com.br/blog/archives/978

    Nos Tutoriais do fórum:
    http://forum.pfsense.org/index.php/topic,8930.0.html

    Tópico relacionado:
    http://forum.pfsense.org/index.php/topic,43736.0.html



  • Bom, na verdade defini os parametros que me foram orientados, inclusive de adicionar uma interface de rede fisica para evitar o gargalo na lan, de fato melhorou, porem apenas com o Mozila firefox a navegação é ótima, quando no IE9… demora muito para carregar as paginas ainda. Então para os novatos que tiverem esse problema de navegação lenta, a solução no meu caso foi adicionar uma interface de rede fisica só para atender ao proxy, ou seja meu servidor tem 3 interfaces fisicas, Wan, Lan1(VM AD), Lan2(VM Proxy).



  • Não entendo porque alguém ainda pensa em usar o Internet Explorer. Tá certo que alguns sites só abrem com ele (culpa de desenvolvedores web ruins), ainda assim, tem como usar o complemento do Firefox conhecido como IE Tab:
    https://addons.mozilla.org/pt-br/firefox/addon/ie-tab/

    O IE Tab é compatível com o Firefox 17.0.

    Sempre uso o Firefox ou Chrome, instalados onde posso.


Locked