Problemas: Squid autenticado e quedas de conexão.



  • Bom dia pessoal,

    Estou com o seguinte problema envolvendo o squid há algum tempo: No meu serviço nós temos um plano de internet que devido a razões contratuais, o provedor de internet precisa derrubar nossa conexão a cada 2 dias. Após isso, tudo que precisamos é autenticá-lo que ele funciona normalmente. A questão é que eu só tenho conseguido autenticá-lo após reiniciar o firewall, pois o squid bloqueia o acesso de todos os computadores que estavam conectados naquele momento. Tentei desconectar um dos Pcs e conectar novamente  como medida de teste. Até aparece a tela do squid solicitando autenticação, mas a internet não funciona da mesma forma, inclusive dá erro de DNS. Dei uma olhada nos logs do sistema e não notei algo que possa me servir de luz para solicionar a questão.
    Agradeço de antemão àqueles  que puderem me ajudar. ;D



  • já tentou colocar um restart do squid via cron todo dia após o restart do provedor?



  • @marcelloc:

    já tentou colocar um restart do squid via cron todo dia após o restart do provedor?

    Marcelloc,

    Eu não tinha noção que existia esse pacote. Vou tentar configurá-lo para esse tipo de situação. Mas existe um agravante: Não há uma hora precisa para ocorrer o restart do provedor (ocorre de 2 em 2 dias, mas não exatamente às 9 horas, pode ocorrer às 23h, por exemplo) Como eu poderia configurar o Cron para fazer o restart automaticamente sabendo dessa condição?

    Hoje ocorreu novamente essa situação e observei uma outra coisa: Lá no shell do pfsense a WAN "perdeu o IP" (Não tinha mais o IP do provedor). Ele só volta com o IP correto após a reinicialização do firewall.



  • @arcmaster:

    Hoje ocorreu novamente essa situação e observei uma outra coisa: Lá no shell do pfsense a WAN "perdeu o IP" (Não tinha mais o IP do provedor). Ele só volta com o IP correto após a reinicialização do firewall.

    Talvez seja melhor fazer um script para dar boot no pfsense então. Perder o endereço da wan é dificil(pra não dizer um palavrão  ;))…

    Sua autenticação é via pppoe ou recebe o ip via dhcp?



  • @marcelloc:

    @arcmaster:

    Hoje ocorreu novamente essa situação e observei uma outra coisa: Lá no shell do pfsense a WAN "perdeu o IP" (Não tinha mais o IP do provedor). Ele só volta com o IP correto após a reinicialização do firewall.

    Talvez seja melhor fazer um script para dar boot no pfsense então. Perder o endereço da wan é dificil(pra não dizer um palavrão  ;))…

    Sua autenticação é via pppoe ou recebe o ip via dhcp?

    A autenticação é via dhcp meu amigo.  ;D



  • @arcmaster:

    A autenticação é via dhcp meu amigo.  ;D

    Já tentou reiniciar o dhclient via console/script quando o ping para um endereço externo não funcionar?


Locked