Short host names don't resolve?



  • I am testing pfSense at the moment - currently it's WAN configuration is obtained by DHCP - it's gateway is a Windows 2003 SBS server running DNS, DHCP and ISA (blegh!), which then connects to a Sonicwall.

    I have set up our pfSense to use our SBS box as its DNS server (with the tick box about DHCP overriding), and enabled the DNS forwarder. I have also set up our domain name in the General Setup area.

    I have a couple of test machines using pfSense as their gateway/dns server.

    The problem I have is that these users have software that connects to our Exchange Server using the short host name ("exchange") - and this short host name no longer works. In order to get it working I need to configure the software to use the name "exchange.ourdomain.com".

    I have tried entering manual forwarders in pfSense, however this still does not work (it does if I do a dnslookup on the machine, but not when entering the short host in a web browser).

    So that once we go "live" with pfSense as our gateway, is there a way I can have it automatically resolve short hostnames?

    Cheers,
    Kim



  • It should automatically resolve hostnames if the DHCP server is enabled for an interface.  You can also add custom entries in Services -> DNS Forwarder.


Log in to reply