CF Boot



  • Hi all!

    i have a problem with my first installation of pfsense over a CF 2GB.
    During the boot i receive this messages from the console:

    Welcome to pfSense 1.0.1 on the 'embedded' platform…                                                     
    Setting up embedded specific environment... done.                                               
    Mounting filesystems...ad0: TIMEOUT - WRITE retrying (1 retry left) LBA=1904                                                                           
    ad0: TIMEOUT - WRITE retrying (1 retry left) LBA=16                                                 
    ad0: TIMEOUT - WRITE retrying (0 retries left) LBA=16                                                   
    ad0: FAILURE - WRITE timed out LBA=16                                   
    mount: /dev/ufs/pfSense: Input/output error                                         
    ** /dev/ufs/pfSense (NO WRITE)                             
    ** Last Mounted on /tmp/freesbie.sujxdzSs                                       
    ** Root file system                 
    ** Phase 1 - Check Blocks and Sizes                                 
    ** Phase 2 - Check Pathnames
    ** Phase 3 - Check Connectivity
    ** Phase 4 - Check Reference Counts
    ** Phase 5 - Check Cyl groups
    1969 files, 51851 used, 61904 free (2368 frags, 7442 blocks, 2.1% fragmentation)

    ad0: TIMEOUT - WRITE retrying (1 retry left) LBA=64
    ad0: TIMEOUT - WRITE retrying (0 retries left) LBA=64
    ad0: FAILURE - WRITE timed out LBA=64
    ad0: TIMEOUT - WRITE retrying (1 retry left) LBA=64
    ad0: TIMEOUT - WRITE retrying (0 retries left) LBA=64
    ad0: FAILURE - WRITE timed out LBA=64
    ad0: TIMEOUT - WRITE retrying (1 retry left) LBA=16
    ad0: TIMEOUT - WRITE retrying (1 retry left) LBA=117680
    ad0: TIMEOUT - WRITE retrying (0 retries left) LBA=16
    ad0: TIMEOUT - WRITE retrying (0 retries left) LBA=117680
    ad0: FAILURE - WRITE timed out LBA=16
    ad0: FAILURE - WRITE timed out LBA=117680
    ad0: TIMEOUT - WRITE retrying (1 retry left) LBA=117888
    ad0: TIMEOUT - WRITE retrying (1 retry left) LBA=64
    ad0: TIMEOUT - WRITE retrying (0 retries left) LBA=117888
    ad0: TIMEOUT - WRITE retrying (0 retries left) LBA=64
    ad0: FAILURE - WRITE timed out LBA=117888

    Can you help me, please?!!



  • I had the same issues as you.  I'm using one of those little Hacom systems for my pfSense install, and I initially wanted to use a super-fast 1GB CF card to install it, but had all those DMA timeouts.  Via Google searches I saw lots of suggestions to disable UDMA and to set the access mode of the port (for the Hacom using CF it's Master on the Secondary controller) to CHS.  That didn't help, but I tried a 256MB card and that worked.  However I didn't want to use a small 256MB card so I went to some stores and bought the cheapest 1GB CF cards I could buy.  Sure enough, some cheap 1GB CF card that was on sale for $12 worked immediately.  I even bought another one to have as a backup.

    I don't know if this will help or not, but you may want to first bring down the speed of the interface you're connecting the CF card to down to non-UDMA.  Second, try some other cards.  I suspect that the nice high-speed CF cards have less of a chance of working than the el-cheapo CF cards.  Just a guess.


Log in to reply