Gateways disappear under certain circumstances



  • I have encountered what appears to be a bug while working on a multi WAN configuration.
    I have many gateways defined due to many interfaces. I have 3 LANs and 6 WANs.
    There are 3 WANs in particular which I am testing in a Gateway Group, I will refer to them as W1, W2, W3.
    Here is what I did:

    • Set W2 to default GW
    • Disconnected the W2 connection
    • Observed  it go Offline and get removed from the Gateway Group, all was well.
    • Observed that the Gateway Group did not work by sending traffic to the other W1/W3 connections
    • Went to Routing->Gateways and set W1 as default GW
    • Observed that W3 disappeared completely from the table of Gateways, and W1 did not become default
    • Tried setting W1 as default GW again, again another Gateway disappeared.
    • Tried setting a different default GW as default, again another Gateway disappeared

    In summary when I try to make a change to a GW, it deletes another GW. I revert back to a previous config, and can repeat the steps and get the same result. This happens when I click the SAVE button while editing any GW even if I do not make changes to the GW page.

    Does anyone have any idea what may be going on here? I am on the latest snapshot, 2.1-BETA0 (amd64) NOV 29 20:21:43 EST 2012, and this also occured on a NOV 26 snapshot which is where I first noticed it. I waited a few days to try a newer snapshot before reporting.

    Thanks!

    CHgsd


  • Rebel Alliance Developer Netgate

    I can't seem to reproduce this on a VM on a Nov 29th snapshot.

    The only change in the last 3 months or so was some parameter encoding I changed at the end of October, and one of those fields was the id field, so I could see that being a potential issue, but given that I can't seem to reproduce what you're seeing it's a bit of a conundrum.

    Do you mind posting the contents of the gateways section of your config.xml?


Locked