Squidgaurd: IP whitelist



  • I am trying to keep the setting enable:
    "Not to allow IP addresses in URL"
    But i need to keep these IPaddresses exempt from this rule in my home network:(steam/steam content servers)
    It would be nice to get the list from the one I use in pfblocker (wishful none existent thinking)

    
    DATE/TIME	IP/NAME	USERID	TYPE	ACCESSED SITE
    2012-12-02 00:51	192.168.1.20	-	GET	81.171.68.195
    2012-12-02 00:51	192.168.1.20	-	GET	81.171.68.194
    2012-12-02 00:51	192.168.1.20	-	GET	80.239.194.138
    2012-12-02 00:51	192.168.1.20	-	GET	80.239.130.254
    2012-12-02 00:51	192.168.1.20	-	GET	77.67.60.50
    2012-12-02 00:51	192.168.1.20	-	GET	77.67.60.130
    2012-12-02 00:51	192.168.1.20	-	GET	212.162.18.102
    2012-12-02 00:51	192.168.1.20	-	GET	80.239.194.154
    2012-12-02 00:51	192.168.1.20	-	GET	80.239.194.150
    2012-12-02 00:51	192.168.1.20	-	GET	79.141.166.2
    2012-12-02 00:51	192.168.1.20	-	GET	77.67.60.42
    2012-12-02 00:51	192.168.1.20	-	GET	77.67.56.186
    2012-12-02 00:51	192.168.1.20	-	GET	212.73.205.178
    2012-12-02 00:51	192.168.1.20	-	GET	212.73.203.62
    2012-12-02 00:51	192.168.1.20	-	GET	212.162.11.102
    2012-12-02 00:50	192.168.1.20	-	GET	80.239.194.162
    2012-12-02 00:50	192.168.1.20	-	GET	77.67.56.178
    2012-12-02 00:50	192.168.1.20	-	GET	212.187.201.122
    2012-12-02 00:50	192.168.1.20	-	GET	212.187.192.162
    2012-12-02 00:50	192.168.1.20	-	GET	212.187.192.158
    2012-12-02 00:50	192.168.1.20	-	GET	212.187.192.14
    2012-12-02 00:50	192.168.1.20	-	GET	212.162.17.202
    2012-12-02 00:50	192.168.1.20	-	GET	209.197.10.86
    2012-12-02 00:50	192.168.1.20	-	GET	209.197.10.85
    2012-12-02 00:50	192.168.1.20	-	GET	80.239.194.146
    2012-12-02 00:50	192.168.1.20	-	GET	77.67.60.34
    2012-12-02 00:50	192.168.1.20	-	GET	77.67.60.154
    2012-12-02 00:50	192.168.1.20	-	GET	74.209.135.131
    2012-12-02 00:50	192.168.1.20	-	GET	62.140.24.122
    2012-12-02 00:50	192.168.1.20	-	GET	212.72.40.138
    2012-12-02 00:50	192.168.1.20	-	GET	212.162.25.34
    2012-12-02 00:50	192.168.1.20	-	GET	194.124.229.17
    2012-12-02 00:50	192.168.1.20	-	GET	81.171.115.13
    2012-12-02 00:50	192.168.1.20	-	GET	81.171.115.12
    2012-12-02 00:50	192.168.1.20	-	GET	81.171.115.11
    2012-12-02 00:50	192.168.1.20	-	GET	80.239.194.134
    2012-12-02 00:50	192.168.1.20	-	GET	80.239.160.42
    2012-12-02 00:50	192.168.1.20	-	GET	77.67.56.162
    2012-12-02 00:50	192.168.1.20	-	GET	212.73.249.22
    2012-12-02 00:50	192.168.1.20	-	GET	146.66.153.250
    
    

    Obvious squid error:

    Client group: default
    Target group: in-addr
    URL: http://212.162.25.34/ 
    
    

    I like to have this option on for kids who are getting smarter with computers.But not block everything. I will need to add some rules for some of my remote servers as well.

    Thanks,
    nez



  • Hi,

    if you enabled "Not to allow IP addresses in URL" then users are not allowed to use an IP address in the browsers URL.

    To bypass this for some specific URLs/IP-addresses you must create a target and whitelist this target.

    So create a target and add all the destination IPs you want to whitelist.
    The on "Group ACL" or "Common ACL" select this target as "Whitelist"

    This should work - even if "Not to allow IP addresses in URL" is enabled.

    But I do not see a way to automatically use the IPs from pfblocker.


Locked