NUT is enabled, however the service is not running!

  • I recently downloaded NUT 2.6.4 pkg 2.0, briefly configured it and started the service. However, I noticed in my System Logs tab that it hadn't started. I referred the docs page for NUT and saw the following:

    If the system log doesn't offer adequate information, such as simply logging "nut: Service failed to start: check configuration", log in via SSH and choose option 8, then run:

    /usr/local/etc/rc.d/ start

    And you will see the error in your configuration.

    I checked my logs and sure enough I received the following:

    php: nut: Service failed to start: check configuration
    php: nut: Starting service

    So I fired up SSH, issued the command and got this:

    Enter an option: 8

    [2.0.1-RELEASE]/root(1): /usr/local/etc/rc.d/ start
    starting cyberpower
    Network UPS Tools - UPS driver controller 2.6.4
    Can't start /usr/local/libexec/nut/cyberpower: No such file or directory
    cyberpower failed to start

    It appears as though my CyberPower UPS isn't supported in this package. If the package is updated, I'll be glad to test it out and report my results in this thread. Otherwise, some advice on this issue would be appreciated. Thanks!

  • I have run many different models of ups and 3 of them were cyberpower on pfsense. I have not used the cyber power option in the config screen since it would never work. I have been successful with using local ups model APC Back-ups usb local port auto usb. This seems to be the generic one that works for all of them. :-D I havent changed it for the 5 different ups models/brands that I use. Give that one a shot and see if it works for ya.

  • Thanks mate! That seemed to do it for me. I appreciate the help.

  • Awesome! Glad it works for ya.

Log in to reply