WPAD problem with lighttpd url.redirect



  • I had problems with my wpad.dat file on my pfsense. There was always an redirect so it was ignored by the browser.
    So I changed in system.inc following code to make an exception for wpad subdomains.
    From:

    
    \$SERVER["socket"] == ":80" {
    	\$HTTP["host"] =~ "(.*)" {
    		url.redirect = ( "^/(.*)" => "https://%1{$redirectport}/$1" )
    	}
    }
    
    

    to

    
    \$SERVER["socket"] == ":80" {
    	\$HTTP["host"] !~ "^wpad\.(.*)$" {
    		\$HTTP["host"] !~ "wpad$" {
    			\$HTTP["host"] =~ "(.*)" {
    				url.redirect = ( "^/(.*)" => "https://%1{$redirectport}/$1" )
    			}
    		}
    	}
    }
    
    

    Is there another way to do this without changing system files?



  • Just put your GUI on port 80?
    That redirect is just to have transparent ssl support for many people it was not meant to have special cases for WPAD.



  • Hi

    I tried suggestion from redgolem, it works fine for Firefox, but does not work for IE, I looked at the wireshark content , pfsense returns a http error 301
    . it is still looking for wpad in https location.

    I don't want to enable http access for webconfigurator for security reasons,

    I am running 2.1 version of pfsense



  • Which url is reqested from your Internet Explorer?
    It should be http://wpad/wpad.dat or http://wpad.some.domain/wpad.dat .